curl: disable zstd support
[openwrt/openwrt.git] / package / network / utils / curl / Makefile
index c483ec1186df3e8e04d8f4a342d22b77843c9b69..c70bfdff20fc285b576a61d51ed2ef659576848a 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.69.1
-PKG_RELEASE:=1
+PKG_VERSION:=7.72.0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        https://curl.mirror.anstey.ca/ \
        https://curl.askapache.com/download/ \
        https://curl.haxx.se/download/
-PKG_HASH:=03c7d5e6697f7b7e40ada1b2256e565a555657398e6c1fcfa4cb251ccd819d4f
+PKG_HASH:=0ded0808c4d85f2ee0db86980ae610cc9d165e9ca9da466196cc73c346513713
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -118,6 +118,7 @@ CONFIGURE_ARGS += \
        --without-libidn \
        --without-ca-path \
        --without-libpsl \
+       --without-zstd \
        --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
        \
        $(call autoconf_bool,CONFIG_IPV6,ipv6) \