curl: disable zstd support
authorHans Dedecker <dedeckeh@gmail.com>
Sun, 23 Aug 2020 08:47:04 +0000 (10:47 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sun, 23 Aug 2020 09:03:40 +0000 (11:03 +0200)
Fixes package libcurl build issue :

Package libcurl is missing dependencies for the following libraries:
libzstd.so.1

Suggested-by: Syrone Wong <wong.syrone@gmail.com>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/utils/curl/Makefile

index f53621a8589ed857e89a5672456957a6997f3cc9..c70bfdff20fc285b576a61d51ed2ef659576848a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
 PKG_VERSION:=7.72.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
@@ -118,6 +118,7 @@ CONFIGURE_ARGS += \
        --without-libidn \
        --without-ca-path \
        --without-libpsl \
+       --without-zstd \
        --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
        \
        $(call autoconf_bool,CONFIG_IPV6,ipv6) \