curl: disable zstd support
[openwrt/openwrt.git] / package / network / utils / curl / Makefile
index f2a7406164acfc3689588649b146db8962ba2b34..c70bfdff20fc285b576a61d51ed2ef659576848a 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.70.0
-PKG_RELEASE:=1
+PKG_VERSION:=7.72.0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        https://curl.mirror.anstey.ca/ \
        https://curl.askapache.com/download/ \
        https://curl.haxx.se/download/
-PKG_HASH:=032f43f2674008c761af19bf536374128c16241fb234699a55f9fb603fcfbae7
+PKG_HASH:=0ded0808c4d85f2ee0db86980ae610cc9d165e9ca9da466196cc73c346513713
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -118,6 +118,7 @@ CONFIGURE_ARGS += \
        --without-libidn \
        --without-ca-path \
        --without-libpsl \
+       --without-zstd \
        --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
        \
        $(call autoconf_bool,CONFIG_IPV6,ipv6) \