change the opkg path due to changes in the buildsystem, fixes incorrect path in snaps...
[openwrt/svn-archive/archive.git] / package / opkg / Makefile
index 491d52e43208e7f9e2b9f6130af18ca20c83fa80..243e0b6d3f2a5ea639b275b315eddd88985bdfe3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_REV:=503
+PKG_REV:=513
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -47,7 +47,8 @@ EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 CONFIGURE_ARGS += \
        --disable-curl \
        --disable-gpg \
-       --with-ipkgetcdir=/etc
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/var/lock/opkg.lock
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
@@ -69,7 +70,7 @@ define Package/opkg/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/opkg.conf $(1)/etc/
-       $(SED) 's,$$$$S,$(PKGARCH),g' $(1)/etc/opkg.conf
+       $(SED) 's,$$$$S,$(TARGET),g' $(1)/etc/opkg.conf
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
 endef