kernel: move kmod-i2c-bcm-iproc to I2C menu
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 2af0da5484db1dec2d910eb32f5dd2d434a0a068..f980f8a8fbf43e8000e49227b85d098d8c9b7c30 100644 (file)
@@ -8,22 +8,25 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
-FEATURES:=squashfs usb pci pcie gpio
-MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
+FEATURES:=squashfs nand usb pci pcie gpio pwm
+CPU_TYPE:=cortex-a9
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.10.2
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfp -mfloat-abi=softfp
+include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))