kernel: move kmod-i2c-bcm-iproc to I2C menu
authorDaniel Golle <daniel@makrotopia.org>
Fri, 30 Oct 2020 15:45:42 +0000 (15:45 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 30 Oct 2020 15:47:52 +0000 (15:47 +0000)
A typo resulted in that module having it's own menu.
Move it into the I2C menu as it was most likely intended.

Fixes: 1291274335 ("kernel: package bcm53xx i2c module")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/bcm53xx/modules.mk

index ab3bab3f1557006f2d7874635777f261657ef9d4..6432a7f577452522736764ed101a8e7501c7b8fc 100644 (file)
@@ -40,7 +40,7 @@ define KernelPackage/i2c-bcm-iproc
   TITLE:=Broadcom iProc I2C controller
   KCONFIG:=CONFIG_I2C_BCM_IPROC
   DEPENDS:=@TARGET_bcm53xx +kmod-i2c-core
-  SUBMENU:=(I2C_MENU)
+  SUBMENU:=$(I2C_MENU)
   FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-bcm-iproc.ko
   AUTOLOAD:=$(call AutoLoad,59,i2c-bcm-iproc,1)
 endef