kernel: move kmod-i2c-bcm-iproc to I2C menu
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 51b80dbb98efb57929fd2f98957f9089d9903b1a..f980f8a8fbf43e8000e49227b85d098d8c9b7c30 100644 (file)
@@ -9,22 +9,24 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
-FEATURES:=squashfs nand usb pci pcie gpio
-MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+FEATURES:=squashfs nand usb pci pcie gpio pwm
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.14.18
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
+       kmod-gpio-button-hotplug \
        kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))