kernel: move kmod-i2c-bcm-iproc to I2C menu
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 731eae1ac3d29de4f1de732e204003b7b95c6132..f980f8a8fbf43e8000e49227b85d098d8c9b7c30 100644 (file)
@@ -9,21 +9,23 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
-FEATURES:=squashfs nand usb pci pcie gpio
-MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+FEATURES:=squashfs nand usb pci pcie gpio pwm
 CPU_TYPE:=cortex-a9
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=3.14
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
        kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer