kernel/modules: fix chipidea
[openwrt/svn-archive/archive.git] / target / linux / mxs / modules.mk
index 0584a731bd33085043799fe44a5fc9092451e37f..10ea3d685f6229a52cf125fa10a1e6fedd712a62 100644 (file)
@@ -33,22 +33,6 @@ endef
 
 $(eval $(call KernelPackage,wdt-stmp3xxx))
 
-define KernelPackage/usb-chipidea-imx
-    TITLE:=Support for ChipIdea controllers on Freescale i.MX SoCs
-    DEPENDS:=+kmod-usb-chipidea @TARGET_mxs
-    FILES:= \
-       $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko \
-       $(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko
-    AUTOLOAD:=$(call AutoLoad,52,usbmisc_imx ci_hdrc_imx,1)
-    $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-chipidea-imx/description
-    Kernel support for USB ChipIdea controllers on Freescale i.MX SoCs
-endef
-
-$(eval $(call KernelPackage,usb-chipidea-imx,1))
-
 define KernelPackage/sound-soc-mxs
     TITLE:=Freescale i.MX23/i.MX28 built-in SoC sound support
     KCONFIG:= \
@@ -63,7 +47,7 @@ define KernelPackage/sound-soc-mxs
     DEPENDS:=@TARGET_mxs +kmod-sound-soc-core
     $(call AddDepends/sound)
 endef
-  
+
 define KernelPackage/sound-soc-mxs/description
     Kernel support for Freescale i.MX23/i.MX28 built-in SoC audio
 endef
@@ -89,9 +73,9 @@ $(eval $(call KernelPackage,iio-mxs-lradc))
 define KernelPackage/crypto-hw-dcp
     TITLE:=i.MX23/28 DCP hardware crypto module
     DEPENDS:=@TARGET_mxs
-    KCONFIG:=CONFIG_CRYPTO_DEV_DCP
-    FILES:=$(LINUX_DIR)/drivers/crypto/dcp.ko
-    AUTOLOAD:=$(call AutoLoad,90,dcp)
+    KCONFIG:=CONFIG_CRYPTO_DEV_MXS_DCP
+    FILES:=$(LINUX_DIR)/drivers/crypto/mxs-dcp.ko
+    AUTOLOAD:=$(call AutoLoad,90,mxs-dcp)
     $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
 endef