kernel/modules: fix chipidea
authorJohn Crispin <john@openwrt.org>
Thu, 11 Dec 2014 18:35:41 +0000 (18:35 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 11 Dec 2014 18:35:41 +0000 (18:35 +0000)
it should needs to depend on imx and mxs

also remove duplicate kmod definition from mxs target

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 43627

package/kernel/linux/modules/usb.mk
target/linux/imx6/profiles/100-generic.mk
target/linux/imx6/profiles/110-wandboard.mk
target/linux/imx6/profiles/120-gateworks.mk
target/linux/mxs/modules.mk

index 4644cbbe1632fc0492036e547bbcad5110ffcf61..c70057037567ed4bc46135b7b0bd953adca8aaa4 100644 (file)
@@ -1401,9 +1401,9 @@ endef
 $(eval $(call KernelPackage,usbip-server))
 
 
-define KernelPackage/usb-chipidea
+define KernelPackage/usb-chipidea-imx
   TITLE:=Support for ChipIdea controllers
-  DEPENDS:=+kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
+  DEPENDS:=@TARGET_imx6||TARGET_mxs +kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
   KCONFIG:=\
        CONFIG_USB_CHIPIDEA \
        CONFIG_USB_CHIPIDEA_HOST=y \
@@ -1424,12 +1424,12 @@ else
 endif
   $(call AddDepends/usb)
 endef
-  
-define KernelPackage/usb-chipidea/description
+
+define KernelPackage/usb-chipidea-imx/description
  Kernel support for USB ChipIdea controllers
 endef
 
-$(eval $(call KernelPackage,usb-chipidea,1))
+$(eval $(call KernelPackage,usb-chipidea-imx,1))
 
 
 define KernelPackage/usb-mxs-phy
index 91ca3696ad14a2f959ff954d5389bf3b77314609..ec9ebc1fb4a3300c459e0fd704c3a89b0dcab051 100644 (file)
@@ -8,7 +8,7 @@
 define Profile/Generic
   NAME:=Generic (default)
   PACKAGES:= \
-       kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+       kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy \
        uboot-envtools
 endef
 
index 4fa49ec6a61adbca9fc4045bc1104841f1e8f2a1..2b5510fafe88b58baeeb5c10e7448208a7d5683c 100644 (file)
@@ -8,7 +8,7 @@
 define Profile/IMX6DL_WANDBOARD
   NAME:=Wandboard Dual
   PACKAGES:= \
-       kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+       kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy \
        uboot-envtools
 endef
 
index 524e0c45731133903775d62b4c45751e5eede6ef..115021af9cb56f30fcb5b92332245eedf45a9461 100644 (file)
@@ -8,7 +8,7 @@
 define Profile/VENTANA
   NAME:=Gateworks Ventana family
   PACKAGES:= \
-       kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
+       kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
        kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
        kmod-can kmod-can-flexcan kmod-can-raw \
        kmod-rtc-ds1672 kmod-gpio-pca953x kmod-hwmon-gsc kmod-eeprom-at24 \
index 3f9c8f8334e7a0df67dececb49b4369e42861f25..10ea3d685f6229a52cf125fa10a1e6fedd712a62 100644 (file)
@@ -33,22 +33,6 @@ endef
 
 $(eval $(call KernelPackage,wdt-stmp3xxx))
 
-define KernelPackage/usb-chipidea-imx
-    TITLE:=Support for ChipIdea controllers on Freescale i.MX SoCs
-    DEPENDS:=+kmod-usb-chipidea @TARGET_mxs
-    FILES:= \
-       $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko \
-       $(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko
-    AUTOLOAD:=$(call AutoLoad,52,usbmisc_imx ci_hdrc_imx,1)
-    $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-chipidea-imx/description
-    Kernel support for USB ChipIdea controllers on Freescale i.MX SoCs
-endef
-
-$(eval $(call KernelPackage,usb-chipidea-imx,1))
-
 define KernelPackage/sound-soc-mxs
     TITLE:=Freescale i.MX23/i.MX28 built-in SoC sound support
     KCONFIG:= \
@@ -63,7 +47,7 @@ define KernelPackage/sound-soc-mxs
     DEPENDS:=@TARGET_mxs +kmod-sound-soc-core
     $(call AddDepends/sound)
 endef
-  
+
 define KernelPackage/sound-soc-mxs/description
     Kernel support for Freescale i.MX23/i.MX28 built-in SoC audio
 endef