miredo: add debian reproducibility patch 14635/head
authorRosen Penev <rosenp@gmail.com>
Wed, 3 Feb 2021 05:58:48 +0000 (21:58 -0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 3 Feb 2021 06:39:56 +0000 (22:39 -0800)
Refreshed other patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
ipv6/miredo/Makefile
ipv6/miredo/patches/001-fix-musl-pthread-non-portable.patch
ipv6/miredo/patches/002-fix-redefinition-ethadr.patch
ipv6/miredo/patches/003-fix-warnings-portable-defined.patch
ipv6/miredo/patches/004-reproducible.patch [new file with mode: 0644]

index e3498a891cabaebfdcc26aeb4e1b8e268f5d0bb1..f25a86df46451e9a810e14d0d378f493db79e1a4 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miredo
 PKG_VERSION:=1.2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=miredo-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.remlab.net/files/miredo/
index bbaa54c4d7f384e833eef783f1451a9520f9b718..4eb19b037ea3b84c97c4884de158421f87ad2c2c 100644 (file)
@@ -1,6 +1,6 @@
---- a/libteredo/debug.h        2009-02-28 23:17:14.000000000 +0300
-+++ b/libteredo/debug.h        2019-04-07 01:46:48.235087395 +0300
-@@ -43,8 +43,10 @@
+--- a/libteredo/debug.h
++++ b/libteredo/debug.h
+@@ -43,8 +43,10 @@ static inline void debug (const char *st
  #  ifdef __linux__
  #   include <errno.h>
  #   include <assert.h>
@@ -13,7 +13,7 @@
  
  static inline int
  d_pthread_mutex_init (pthread_mutex_t *mutex, pthread_mutexattr_t *pattr)
-@@ -57,7 +59,7 @@
+@@ -57,7 +59,7 @@ d_pthread_mutex_init (pthread_mutex_t *m
                pthread_mutexattr_init (&attr);
        }
  
index 5cd20f4a5d0ad1a03e4ba5af39c6e14c62e0cab0..ead27096dc458f1c6b68a868f5b4526429bd0e90 100644 (file)
@@ -1,5 +1,5 @@
---- a/libtun6/tun6.c   2012-09-12 17:03:59.000000000 +0400
-+++ b/libtun6/tun6.c   2019-04-07 02:21:07.439952535 +0300
+--- a/libtun6/tun6.c
++++ b/libtun6/tun6.c
 @@ -53,7 +53,7 @@
  const char os_driver[] = "Linux";
  # define USE_LINUX 1
@@ -9,7 +9,7 @@
  /*
   * <linux/ipv6.h> conflicts with <netinet/in.h> and <arpa/inet.h>,
   * so we've got to declare this structure by hand.
-@@ -65,7 +65,7 @@
+@@ -65,7 +65,7 @@ struct in6_ifreq {
  };
  
  # include <net/route.h> // struct in6_rtmsg
@@ -18,4 +18,3 @@
  
  typedef struct
  {
-
index d812f7776b290162350f5bb0853d6749819c7f30..a74d77b8f393b686de5c71ddfae3e3f3b3df2db9 100644 (file)
@@ -1,6 +1,6 @@
---- a/include/gettext.h        2012-09-12 16:57:52.000000000 +0400
-+++ b/include/gettext.h        2019-04-07 01:11:52.492519796 +0300
-@@ -182,7 +182,7 @@
+--- a/include/gettext.h
++++ b/include/gettext.h
+@@ -182,7 +182,7 @@ npgettext_aux (const char *domain,
    (((__GNUC__ >= 3 || __GNUG__ >= 2) && !defined(__STRICT_ANSI__)) \
     /* || __STDC_VERSION__ >= 199901L */ )
  
@@ -9,7 +9,7 @@
  #include <stdlib.h>
  #endif
  
-@@ -206,7 +206,7 @@
+@@ -206,7 +206,7 @@ dcpgettext_expr (const char *domain,
    size_t msgctxt_len = strlen (msgctxt) + 1;
    size_t msgid_len = strlen (msgid) + 1;
    const char *translation;
@@ -18,7 +18,7 @@
    char msg_ctxt_id[msgctxt_len + msgid_len];
  #else
    char buf[1024];
-@@ -221,7 +221,7 @@
+@@ -221,7 +221,7 @@ dcpgettext_expr (const char *domain,
        msg_ctxt_id[msgctxt_len - 1] = '\004';
        memcpy (msg_ctxt_id + msgctxt_len, msgid, msgid_len);
        translation = dcgettext (domain, msg_ctxt_id, category);
@@ -27,7 +27,7 @@
        if (msg_ctxt_id != buf)
          free (msg_ctxt_id);
  #endif
-@@ -252,7 +252,7 @@
+@@ -252,7 +252,7 @@ dcnpgettext_expr (const char *domain,
    size_t msgctxt_len = strlen (msgctxt) + 1;
    size_t msgid_len = strlen (msgid) + 1;
    const char *translation;
@@ -36,7 +36,7 @@
    char msg_ctxt_id[msgctxt_len + msgid_len];
  #else
    char buf[1024];
-@@ -267,7 +267,7 @@
+@@ -267,7 +267,7 @@ dcnpgettext_expr (const char *domain,
        msg_ctxt_id[msgctxt_len - 1] = '\004';
        memcpy (msg_ctxt_id + msgctxt_len, msgid, msgid_len);
        translation = dcngettext (domain, msg_ctxt_id, msgid_plural, n, category);
diff --git a/ipv6/miredo/patches/004-reproducible.patch b/ipv6/miredo/patches/004-reproducible.patch
new file mode 100644 (file)
index 0000000..62bae2a
--- /dev/null
@@ -0,0 +1,26 @@
+From: Tomasz Buchert <tomasz@debian.org>
+Date: Fri, 6 Feb 2015 11:33:20 +0100
+Subject: Fix reproducibility issues
+
+We replace unreproducible CC macros with
+N/A placeholders. This fixes #776716.
+---
+ src/main.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- a/src/main.c
++++ b/src/main.c
+@@ -92,10 +92,11 @@ miredo_version (void)
+ #ifndef VERSION
+ # define VERSION "unknown version"
+ #endif
++      const char* UNKNOWN = "N/A";
+       printf (_("Miredo: Teredo IPv6 tunneling software %s (%s)\n"
+                 " built %s on %s (%s)\n"),
+-              VERSION, PACKAGE_HOST, __DATE__,
+-              PACKAGE_BUILD_HOSTNAME, PACKAGE_BUILD);
++              VERSION, UNKNOWN, UNKNOWN,
++              UNKNOWN, UNKNOWN);
+       printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
+       puts (_("Written by Remi Denis-Courmont.\n"));