curl: update to 8.6.0 23219/head
authorKonstantin Demin <rockdrilla@gmail.com>
Thu, 1 Feb 2024 00:28:09 +0000 (03:28 +0300)
committerKonstantin Demin <rockdrilla@gmail.com>
Thu, 1 Feb 2024 00:28:09 +0000 (03:28 +0300)
* https://curl.se/changes.html#8_6_0

Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
net/curl/Makefile
net/curl/patches/200-no_docs_tests.patch

index c41e9ee57a5fd7d54bfd859d01ae9f335b91edda..1969d2dee7dfc4cc199ff62badc97c7e73c20935 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/nls.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=8.5.0
+PKG_VERSION:=8.6.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,
        https://dl.uxnr.de/mirror/curl/ \
        https://curl.askapache.com/download/ \
        https://curl.se/download/
-PKG_HASH:=ce4b6a6655431147624aaf582632a36fe1ade262d5fab385c60f78942dd8d87b
+PKG_HASH:=b4785f2d8877fa92c0e45d7155cf8cc6750dbda961f4b1a45bcbec990cf2fa9b
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index 38f323e26b59e42f59b9a6afab3e45de65a91091..4e0ec1aa3e65ec801e75802d50d42b6c5e32068b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -134,7 +134,7 @@ CLEANFILES = $(VC14_LIBVCXPROJ) \
+@@ -135,7 +135,7 @@ CLEANFILES = $(VC14_LIBVCXPROJ) $(VC14_S
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
@@ -9,7 +9,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -248,8 +248,6 @@ cygwinbin:
+@@ -243,8 +243,6 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        (cd include && $(MAKE) install)