aiccu: fix uClibc build after #1389
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 29 Jun 2015 17:50:01 +0000 (19:50 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 29 Jun 2015 17:50:01 +0000 (19:50 +0200)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
ipv6/aiccu/Makefile
ipv6/aiccu/patches/300-resolver-uclibc.patch
ipv6/aiccu/patches/400-musl-compat.patch

index 0034c0b7091eeb1263ac628dee6f78b13a296d73..dae693839d27ac30acb6fae95b366f52e6eb5500 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
-PKG_RELEASE:=13
+PKG_RELEASE:=14
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
index 1a5f11626e057779aaef6afe115c65b42e721879..b88ef5c1a357f1fa09823e201effb15b125c2da1 100644 (file)
@@ -5,7 +5,7 @@
  int getrrs(const char *label, int rrtype, void gotrec(unsigned int num, int type, const char *record))
  {
 -#ifdef _LINUX
-+#if defined(_LINUX) && defined(__GLIBC__)
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
        struct __res_state      res;
  #endif
        unsigned char           answer[8192];
@@ -14,7 +14,7 @@
        uint32_t                ttl = 0;
  
 -#ifdef _LINUX
-+#if defined(_LINUX) && defined(__GLIBC__)
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
        memset(&res, 0, sizeof(res));
        res.options = RES_DEBUG;
        res_ninit(&res);
  
        memset(answer, 0, sizeof(answer));
 -#ifdef _LINUX
-+#if defined(_LINUX) && defined(__GLIBC__)
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
        ret = res_nquery(&res, label, C_IN, rrtype, answer, sizeof(answer));
  #else
        ret = res_query(label, C_IN, rrtype, answer, sizeof(answer));
---- a/common/dn_skipname.c
-+++ b/common/dn_skipname.c
-@@ -9,7 +9,7 @@
-  * return:
-  *      0 on success, -1 (with errno set) on failure.
-  */
--int ns_name_skip(const u_char **ptrptr, const u_char *eom)
-+static int ns_name_skip(const u_char **ptrptr, const u_char *eom)
- {
-       const u_char *cp;
-       u_int n;
index 2e732d8a2ed8f14bc4a40c94ad69f14e14583e15..b6e0c3236e8442ddfd8b29fa4a25559eaef3de13 100644 (file)
        #include <linux/if_tun.h>
 --- a/common/dn_skipname.c
 +++ b/common/dn_skipname.c
-@@ -1,5 +1,6 @@
+@@ -1,6 +1,8 @@
  #include <errno.h>
  #include <resolv.h>
-+#include <sys/types.h>
  
++#include <sys/types.h>
++
  /* Ripped from glibc 2.4 sources. */
  
+ /*