ddns-scripts: Use https for domains.google.com
authorPaul Tobias <paul@ddproperty.com>
Mon, 26 Aug 2019 11:44:50 +0000 (18:44 +0700)
committerRosen Penev <rosenp@gmail.com>
Thu, 12 Sep 2019 22:26:07 +0000 (15:26 -0700)
Without https the update fails with:

```
 132954       : #> /usr/bin/curl -RsS -o /var/run/ddns/myddns_ipv4.dat --stderr /var/run/ddns/myddns_ipv4.err --noproxy '*' 'http://CENSORED:***PW***@domains.google.com/nic/update?hostname=CENSORED&myip=CENSORED'
 132954       : DDNS Provider answered:
<HTML>
<HEAD>
<TITLE>Moved Temporarily</TITLE>
</HEAD>
<BODY BGCOLOR="#FFFFFF" TEXT="#000000">
<H1>Moved Temporarily</H1>
The document has moved <A HREF="https://domains.google.com/nic/update?hostname=CENSORED&amp;myip=CENSORED">here</A>.
</BODY>
</HTML>
 132954 ERROR : IP update not accepted by DDNS Provider
```

Signed-off-by: Paul Tobias <tobias.pal@gmail.com>
net/ddns-scripts/Makefile
net/ddns-scripts/files/services

index f11c3d52b5382f43981bdf7409b2f0e06e711425..4e7ef2e8c7880c351296aae643a9a9a8c6f37b1f 100755 (executable)
@@ -12,7 +12,7 @@ PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.7.8
 # Release == build
 # increase on changes of services files or tld_names.dat
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=
index db55847b2e24080b29e0198dee4cd8138d07bef4..f6bdbc021bdb28ba28ca1c891b6f0e3ececa54bd 100644 (file)
 
 "goip.de"              "http://www.goip.de/setip?username=[USERNAME]&password=[PASSWORD]&subdomain=[DOMAIN]&ip=[IP]"
 
-"google.com"           "http://[USERNAME]:[PASSWORD]@domains.google.com/nic/update?hostname=[DOMAIN]&myip=[IP]"        "good|nochg"
+"google.com"           "https://[USERNAME]:[PASSWORD]@domains.google.com/nic/update?hostname=[DOMAIN]&myip=[IP]"       "good|nochg"
 
 "he.net"               "http://[DOMAIN]:[PASSWORD]@dyn.dns.he.net/nic/update?hostname=[DOMAIN]&myip=[IP]"      "good|nochg"