python3: Fix package descriptions
authorJeffery To <jeffery.to@gmail.com>
Thu, 13 Jul 2023 05:39:35 +0000 (13:39 +0800)
committerJeffery To <jeffery.to@gmail.com>
Thu, 24 Aug 2023 17:47:42 +0000 (01:47 +0800)
* Fix default Python package description not included in individual
  package descriptions

* Update default Python package description text (from General Python
  FAQ, "What is Python?")

* Add package descriptions for Python module packages

* Reduce duplication in package titles

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
24 files changed:
lang/python/python3/Makefile
lang/python/python3/files/python3-package-asyncio.mk
lang/python/python3/files/python3-package-cgi.mk
lang/python/python3/files/python3-package-codecs.mk
lang/python/python3/files/python3-package-ctypes.mk
lang/python/python3/files/python3-package-dbm.mk
lang/python/python3/files/python3-package-decimal.mk
lang/python/python3/files/python3-package-dev.mk
lang/python/python3/files/python3-package-distutils.mk
lang/python/python3/files/python3-package-email.mk
lang/python/python3/files/python3-package-lib2to3.mk
lang/python/python3/files/python3-package-logging.mk
lang/python/python3/files/python3-package-lzma.mk
lang/python/python3/files/python3-package-multiprocessing.mk
lang/python/python3/files/python3-package-ncurses.mk
lang/python/python3/files/python3-package-openssl.mk
lang/python/python3/files/python3-package-pydoc.mk
lang/python/python3/files/python3-package-readline.mk
lang/python/python3/files/python3-package-sqlite3.mk
lang/python/python3/files/python3-package-unittest.mk
lang/python/python3/files/python3-package-urllib.mk
lang/python/python3/files/python3-package-uuid.mk
lang/python/python3/files/python3-package-venv.mk
lang/python/python3/files/python3-package-xml.mk

index 0d9e2540550decf5fc6d650d074720b94eda31f1..45d14379c4e901897ddcb8c3c9821b8cd72e6d74 100644 (file)
@@ -51,44 +51,52 @@ define Package/python3/Default
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=Python $(PYTHON3_VERSION) programming language
+  TITLE:=Python $(PYTHON3_VERSION)
   URL:=https://www.python.org/
 endef
 
 define Package/python3/Default/description
- Python is a dynamic object-oriented programming language that can be used
- for many kinds of software development. It offers strong support for
- integration with other languages and tools, comes with extensive standard
- libraries, and can be learned in a few days. Many Python programmers
- report substantial productivity gains and feel the language encourages
- the development of higher quality, more maintainable code.
+Python is an interpreted, interactive, object-oriented programming
+language. It incorporates modules, exceptions, dynamic typing, very high
+level dynamic data types, and classes. It supports multiple programming
+paradigms beyond object-oriented programming, such as procedural and
+functional programming. Python combines remarkable power with very clear
+syntax. It has interfaces to many system calls and libraries, as well as
+to various window systems, and is extensible in C or C++. It is also
+usable as an extension language for applications that need a
+programmable interface. Finally, Python is portable: it runs on many
+Unix variants including Linux and macOS, and on Windows.
 endef
 
 define Package/libpython3
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) core library
+  TITLE+= core library
   DEPENDS:=+libpthread
   ABI_VERSION:=$(PYTHON3_VERSION)
 endef
 
 define Package/libpython3/description
-  This package contains only core Python library.
+$(call Package/python3/Default/description)
+
+This package contains only core Python library.
 endef
 
 define Package/python3-base
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) interpreter
+  TITLE+= base interpreter
   DEPENDS:=+libpython3
 endef
 
 define Package/python3-base/description
-  This package contains only the interpreter and the bare minimum
-  for the interpreter to start.
+$(call Package/python3/Default/description)
+
+This package contains only the interpreter and the bare minimum for the
+interpreter to start.
 endef
 
 define Package/python3-light
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) light installation
+  TITLE+= light installation
   DEPENDS:=+python3-base +libbz2 +zlib
 endef
 
@@ -97,9 +105,10 @@ define Package/python3-light/config
 endef
 
 define Package/python3-light/description
-  This package is essentially the python3-base package plus
-  a few of the rarely used (and big) libraries stripped out
-  into separate packages.
+$(call Package/python3/Default/description)
+
+This package installs the base interpreter package and contains the most
+commonly used parts of the standard library.
 endef
 
 PYTHON3_LIB_FILES_DEL:=
@@ -126,12 +135,15 @@ include ./files/python3-package-*.mk
 
 define Package/python3
 $(call Package/python3/Default)
+  TITLE+= programming language
   DEPENDS:=+python3-light $(foreach package,$(PYTHON3_PACKAGES_DEPENDS),+$(package))
 endef
 
 define Package/python3/description
-  This package contains the (almost) full Python install.
-  It's python3-light + all other packages.
+$(call Package/python3/Default/description)
+
+This package installs almost all parts of the standard Python
+installation.
 endef
 
 # Set READELF here so that the exact same readelf program name can be
index 52eccae92d55f5fa4cfc23b08aa3399b27c9e350..c4c31394023b75e9070e571ab6f8d1da9acb51d4 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-asyncio
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) asyncio module
+  TITLE+= asyncio module
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-asyncio/description
+$(call Package/python3/Default/description)
+
+This package contains the asyncio module.
+endef
+
 $(eval $(call Py3BasePackage,python3-asyncio, \
        /usr/lib/python$(PYTHON3_VERSION)/asyncio \
 ))
index 165800a10a844bfc0374b6f5b2222df642444556..e4bb110f17eb812e766eb690c27b3b7dd0dd13d9 100644 (file)
@@ -7,16 +7,27 @@
 
 define Package/python3-cgi
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) cgi module
+  TITLE+= cgi module
   DEPENDS:=+python3-light +python3-email
 endef
 
 define Package/python3-cgitb
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) cgitb module
+  TITLE+= cgitb module
   DEPENDS:=+python3-light +python3-cgi +python3-pydoc
 endef
 
+define Package/python3-cgi/description
+$(call Package/python3/Default/description)
+
+This package contains the cgi module.
+endef
+
+define Package/python3-cgitb/description
+$(call Package/python3/Default/description)
+
+This package contains the cgitb module.
+endef
 
 $(eval $(call Py3BasePackage,python3-cgi, \
        /usr/lib/python$(PYTHON3_VERSION)/cgi.py \
index f768b02ea2e2f76f6939e51ebc8772f1b0f1c511..712cb28ea838e29e80adeae7123f9d58eda2f665 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-codecs
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) codecs + unicode support
+  TITLE+= codecs/Unicode support
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-codecs/description
+$(call Package/python3/Default/description)
+
+This package contains codecs and Unicode support.
+endef
+
 $(eval $(call Py3BasePackage,python3-codecs, \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_codecs_cn.$(PYTHON3_SO_SUFFIX) \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_codecs_hk.$(PYTHON3_SO_SUFFIX) \
index e1bac47cdf4110ab34652e4f9c7d672c5e087ce4..bbd0aff32c7d6d6de2b879df812677c4b4531a11 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-ctypes
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) ctypes module
+  TITLE+= ctypes module
   DEPENDS:=+python3-light +libffi
 endef
 
+define Package/python3-ctypes/description
+$(call Package/python3/Default/description)
+
+This package contains the ctypes module.
+endef
+
 $(eval $(call Py3BasePackage,python3-ctypes, \
        /usr/lib/python$(PYTHON3_VERSION)/ctypes \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_ctypes.$(PYTHON3_SO_SUFFIX) \
index ede9af1631580306ac82eac9e3ad15fee5b74831..3de584fc5dba315b88a8ac2e092caaf68fa0b374 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-dbm
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) dbm module
+  TITLE+= dbm module
   DEPENDS:=+python3-light +libgdbm
 endef
 
+define Package/python3-dbm/description
+$(call Package/python3/Default/description)
+
+This package contains the dbm module.
+endef
+
 $(eval $(call Py3BasePackage,python3-dbm, \
        /usr/lib/python$(PYTHON3_VERSION)/dbm \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_dbm.$(PYTHON3_SO_SUFFIX) \
index 391b6f659a70add5b31d6b29dc5f494966ed0c74..98f632b2b72e060aa8223c3ffe2cb44a21bbf212 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-decimal
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) decimal module
+  TITLE+= decimal module
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-decimal/description
+$(call Package/python3/Default/description)
+
+This package contains the decimal module.
+endef
+
 $(eval $(call Py3BasePackage,python3-decimal, \
        /usr/lib/python$(PYTHON3_VERSION)/decimal.py \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_decimal.$(PYTHON3_SO_SUFFIX) \
index e43ba523491d48509cf4849e9e693827de831580..d9b7e7284299dacbb095d2b65f63ef6ba34ee2e3 100644 (file)
@@ -7,10 +7,17 @@
 
 define Package/python3-dev
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) development files
+  TITLE+= development files
   DEPENDS:=+python3 +python3-lib2to3
 endef
 
+define Package/python3-dev/description
+$(call Package/python3/Default/description)
+
+This package contains files for building Python modules, extending the
+Python interpreter, or embedded Python in applications.
+endef
+
 define Py3Package/python3-dev/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/python$(PYTHON3_VERSION)-config $(1)/usr/bin
index ff3564eea420e4303fbe3b7381c85edffc6280d6..13a8f38cff8ffe56944c97ad42e3375679eeb0c1 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-distutils
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) distutils module
+  TITLE+= distutils module
   DEPENDS:=+python3-light +python3-email
 endef
 
+define Package/python3-distutils/description
+$(call Package/python3/Default/description)
+
+This package contains the distutils module.
+endef
+
 $(eval $(call Py3BasePackage,python3-distutils, \
        /usr/lib/python$(PYTHON3_VERSION)/distutils \
 ))
index 6cf44071d60af8fd8ac8c1cbbc40698ac7dd484d..563f6f8ae3107f43c9695a0f41a24903d6e478d2 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-email
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) email module
+  TITLE+= email module
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-email/description
+$(call Package/python3/Default/description)
+
+This package contains the email module.
+endef
+
 $(eval $(call Py3BasePackage,python3-email, \
        /usr/lib/python$(PYTHON3_VERSION)/email \
 ))
index ed712b6fda8cb541f77aef2d7647995a2674b0c7..c2aa84d1116dbc06e5febbdb59ca52d2acd07681 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-lib2to3
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) lib2to3 module
+  TITLE+= lib2to3 module
   DEPENDS:=+python3
 endef
 
+define Package/python3-lib2to3/description
+$(call Package/python3/Default/description)
+
+This package contains the lib2to3 module.
+endef
+
 $(eval $(call Py3BasePackage,python3-lib2to3, \
        /usr/lib/python$(PYTHON3_VERSION)/lib2to3 \
        , \
index fa3ec0e17a37e7dc762a414186f252e4d9ee8cec..7b770ded82f35d4d5de8aa0fd666f8f5fa3c4791 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-logging
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) logging module
+  TITLE+= logging module
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-logging/description
+$(call Package/python3/Default/description)
+
+This package contains the logging module.
+endef
+
 $(eval $(call Py3BasePackage,python3-logging, \
        /usr/lib/python$(PYTHON3_VERSION)/logging \
 ))
index 57b38eced8bffc164476e1105eb71848d118ce5f..0e984cb7c1514ef06682374c7bc193e2160d7e00 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-lzma
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) lzma module
+  TITLE+= lzma module
   DEPENDS:=+python3-light +liblzma
 endef
 
+define Package/python3-lzma/description
+$(call Package/python3/Default/description)
+
+This package contains the lzma module.
+endef
+
 $(eval $(call Py3BasePackage,python3-lzma, \
        /usr/lib/python$(PYTHON3_VERSION)/lzma.py \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_lzma.$(PYTHON3_SO_SUFFIX) \
index c7976016d9ebec91cb4e2182f5a2e05042e0f77f..7f9b69a44d50d49021b3dc2e8858187c83906873 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-multiprocessing
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) multiprocessing
+  TITLE+= multiprocessing module
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-multiprocessing/description
+$(call Package/python3/Default/description)
+
+This package contains the multiprocessing module.
+endef
+
 $(eval $(call Py3BasePackage,python3-multiprocessing, \
        /usr/lib/python$(PYTHON3_VERSION)/multiprocessing \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_multiprocessing.$(PYTHON3_SO_SUFFIX) \
index 3ecdeb336226051218f654fe71f8fcb074c8454f..5db04b8210b37e0bca6e20816a2da159f095d855 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-ncurses
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) ncurses module
+  TITLE+= ncurses module
   DEPENDS:=+python3-light +libncursesw
 endef
 
+define Package/python3-ncurses/description
+$(call Package/python3/Default/description)
+
+This package contains the ncurses module.
+endef
+
 $(eval $(call Py3BasePackage,python3-ncurses, \
        /usr/lib/python$(PYTHON3_VERSION)/curses \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_curses.$(PYTHON3_SO_SUFFIX) \
index 4d13afd2026f1bc6069da1825e2d938757e7c8c7..eec9daf8c028ddbb8df99f566bc3bbbf940f7512 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-openssl
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) SSL module
+  TITLE+= ssl module
   DEPENDS:=+python3-light +libopenssl +ca-certs
 endef
 
+define Package/python3-openssl/description
+$(call Package/python3/Default/description)
+
+This package contains the ssl module.
+endef
+
 $(eval $(call Py3BasePackage,python3-openssl, \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_hashlib.$(PYTHON3_SO_SUFFIX) \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_ssl.$(PYTHON3_SO_SUFFIX) \
index 9ab1a5b8bac027d744a5b65a2da9e5e584544e4c..d5bbe7c3d18f565e288e6db4cdfbebe52068745b 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-pydoc
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) pydoc module
+  TITLE+= pydoc module
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-pydoc/description
+$(call Package/python3/Default/description)
+
+This package contains the pydoc module.
+endef
+
 $(eval $(call Py3BasePackage,python3-pydoc, \
        /usr/lib/python$(PYTHON3_VERSION)/doctest.py \
        /usr/lib/python$(PYTHON3_VERSION)/pydoc.py \
index fbff134a34db53f18f1d7a2bcd98addcef8a075a..846b71168b31592b9ac0de1e9a5596d23567ea76 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-readline
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) readline module
+  TITLE+= readline module
   DEPENDS:=+python3-light +libreadline
 endef
 
+define Package/python3-readline/description
+$(call Package/python3/Default/description)
+
+This package contains the readline module.
+endef
+
 $(eval $(call Py3BasePackage,python3-readline, \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/readline.$(PYTHON3_SO_SUFFIX) \
 ))
index 665bff26acba21925ddb1daac3ddae1bb8943d65..06f34be6b91a67aa7c1bc350d1dda9005cbd9c74 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-sqlite3
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) sqlite3 module
+  TITLE+= sqlite3 module
   DEPENDS:=+python3-light +libsqlite3
 endef
 
+define Package/python3-sqlite3/description
+$(call Package/python3/Default/description)
+
+This package contains the sqlite3 module.
+endef
+
 $(eval $(call Py3BasePackage,python3-sqlite3, \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_sqlite3.$(PYTHON3_SO_SUFFIX) \
        /usr/lib/python$(PYTHON3_VERSION)/sqlite3 \
index d9df86f719ca6497ca31198aa8bd417705a663b0..eb5f09ec45f6fa395d0ad4405ca422c600c5fd2d 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-unittest
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) unittest module
+  TITLE+= unittest module
   DEPENDS:=+python3-light
 endef
 
+define Package/python3-unittest/description
+$(call Package/python3/Default/description)
+
+This package contains the unittest module.
+endef
+
 $(eval $(call Py3BasePackage,python3-unittest, \
        /usr/lib/python$(PYTHON3_VERSION)/unittest \
 ))
index ddd7b1dbfb57ced9e8f22b66849a316eea801bf9..e84e589debd3870edc211a8930292fee8cc92f93 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-urllib
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) URL library module
+  TITLE+= URL handling modules
   DEPENDS:=+python3-light +python3-email
 endef
 
+define Package/python3-urllib/description
+$(call Package/python3/Default/description)
+
+This package contains the URL handling modules.
+endef
+
 $(eval $(call Py3BasePackage,python3-urllib, \
        /usr/lib/python$(PYTHON3_VERSION)/urllib \
 ))
index ef05c5902d334a0314326acf1d7236a83c6114cd..ae188738b619e5ab18f0462cd2567daba1812fbf 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-uuid
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) UUID module
+  TITLE+= uuid module
   DEPENDS:=+python3-light +libuuid
 endef
 
+define Package/python3-uuid/description
+$(call Package/python3/Default/description)
+
+This package contains the uuid module.
+endef
+
 $(eval $(call Py3BasePackage,python3-uuid, \
        /usr/lib/python$(PYTHON3_VERSION)/uuid.py \
        /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_uuid.$(PYTHON3_SO_SUFFIX) \
index b2ddcab797917dae0c00345e341ae58ad40d6a5a..536c985ffe7f24c42570b5140ce0ec0eba9bbb40 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-venv
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) venv module
+  TITLE+= venv module
   DEPENDS:=+python3
 endef
 
+define Package/python3-venv/description
+$(call Package/python3/Default/description)
+
+This package contains the venv module.
+endef
+
 $(eval $(call Py3BasePackage,python3-venv, \
        /usr/lib/python$(PYTHON3_VERSION)/ensurepip \
        /usr/lib/python$(PYTHON3_VERSION)/venv \
index 84b2ce056bb3b424397684ac0bd5923a6c1fcac3..97669e5dd4f2ce9c01cd02f4d5fb739a22f53504 100644 (file)
@@ -7,10 +7,16 @@
 
 define Package/python3-xml
 $(call Package/python3/Default)
-  TITLE:=Python $(PYTHON3_VERSION) xml libs
+  TITLE+= XML modules
   DEPENDS:=+python3-light +python3-urllib
 endef
 
+define Package/python3-xml/description
+$(call Package/python3/Default/description)
+
+This package contains the XML modules.
+endef
+
 $(eval $(call Py3BasePackage,python3-xml, \
        /usr/lib/python$(PYTHON3_VERSION)/xml \
        /usr/lib/python$(PYTHON3_VERSION)/xmlrpc \