curl: enable unix sockets by default 20600/head
authorOskari Rauta <oskari.rauta@gmail.com>
Mon, 6 Mar 2023 12:14:14 +0000 (12:14 +0000)
committerOskari Rauta <oskari.rauta@gmail.com>
Sun, 12 Mar 2023 16:55:27 +0000 (16:55 +0000)
 - changed Config.in to enable unix sockets support by default
 - release number bumped

Description:
socket support is very handy when communicating with
various REST APIs.

Size increases are very small, nearly unnoticiable.

Tested-by: Stan Grishin <stangri@melmac.ca>
Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
net/curl/Config.in
net/curl/Makefile

index 5e7e554d7b41c3b32ae4a9172f8edc8877ab348e..24b7b9627188437e986c3015765c7e369019fe2c 100644 (file)
@@ -139,7 +139,7 @@ config LIBCURL_ZSTD
 
 config LIBCURL_UNIX_SOCKETS
        bool "Enable unix domain socket support"
-       default n
+       default y
        help
                Enable HTTP over unix domain sockets.
                To use this with the curl command line, you specify the socket path to the new --unix-domain option.
index 94dd07ff67621b1f4320b4d3a6b6e63b15e30e2d..0864d51439d6b8741dca87b2fb039896da53f026 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/nls.mk
 
 PKG_NAME:=curl
 PKG_VERSION:=7.88.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,$(PKG_VERSION))/ \