qrencode: Completely remove libpng dependency from package configure
authorTed Hess <thess@kitschensync.net>
Mon, 25 May 2015 20:31:36 +0000 (16:31 -0400)
committerTed Hess <thess@kitschensync.net>
Mon, 25 May 2015 20:31:36 +0000 (16:31 -0400)
Signed-off-by: Ted Hess <thess@kitschensync.net>
libs/qrencode/Makefile
libs/qrencode/patches/001-disable-png.patch

index 8d70b4a05be3e6ade28a24ed43c836ab0d7ad925..db2d69713af5bf75f0ad1ac7246702c90da9bdd0 100644 (file)
@@ -21,8 +21,6 @@ PKG:FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_BUILD_DEPENDS:=libpng
-
 define Package/libqrencode
   SECTION:=libs
   CATEGORY:=Libraries
index 2549ee6fcacd168f3393065edf8bdb876b835144..8ede38c250bf1e03820f4543cb7d02d957e66625 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -58,9 +58,6 @@
+@@ -58,9 +58,6 @@ AC_ARG_WITH([tools], [AS_HELP_STRING([--
   [build_tools=$withval], [build_tools=yes])
  
  AM_CONDITIONAL(BUILD_TOOLS, [test "x$build_tools" = "xyes" ])
@@ -20,7 +20,7 @@
  #include <getopt.h>
  
  #include "qrencode.h"
-@@ -49,7 +48,6 @@
+@@ -49,7 +48,6 @@ static unsigned int bg_color[4] = {255,
  static int verbose = 0;
  
  enum imageType {
@@ -28,7 +28,7 @@
        EPS_TYPE,
        SVG_TYPE,
        ANSI_TYPE,
-@@ -60,7 +58,7 @@
+@@ -60,7 +58,7 @@ enum imageType {
        ANSIUTF8_TYPE
  };
  
@@ -37,7 +37,7 @@
  
  static const struct option options[] = {
        {"help"         , no_argument      , NULL, 'h'},
-@@ -96,13 +94,13 @@
+@@ -96,13 +94,13 @@ static void usage(int help, int longopt)
                if(longopt) {
                        fprintf(stderr,
  "Usage: qrencode [OPTION]... [STRING]\n"
@@ -53,7 +53,7 @@
  "               (suffix is removed from FILENAME, if specified)\n"
  "  -s NUMBER, --size=NUMBER\n"
  "               specify module size in dots (pixels). (default=3)\n\n"
-@@ -116,9 +114,9 @@
+@@ -116,9 +114,9 @@ static void usage(int help, int longopt)
  "               specify the width of the margins. (default=4 (2 for Micro QR)))\n\n"
  "  -d NUMBER, --dpi=NUMBER\n"
  "               specify the DPI of the generated PNG. (default=72)\n\n"
@@ -65,7 +65,7 @@
  "  -S, --structured\n"
  "               make structured symbols. Version must be specified.\n\n"
  "  -k, --kanji  assume that the input text contains kanji (shift-jis).\n\n"
-@@ -133,7 +131,7 @@
+@@ -133,7 +131,7 @@ static void usage(int help, int longopt)
  "      --background=RRGGBB[AA]\n"
  "               specify foreground/background color in hexadecimal notation.\n"
  "               6-digit (RGB) or 8-digit (RGBA) form are supported.\n"
@@ -74,7 +74,7 @@
  "  -V, --version\n"
  "               display the version number and copyrights of the qrencode.\n\n"
  "      --verbose\n"
-@@ -153,12 +151,12 @@
+@@ -153,12 +151,12 @@ static void usage(int help, int longopt)
                } else {
                        fprintf(stderr,
  "Usage: qrencode [OPTION]... [STRING]\n"
@@ -89,7 +89,7 @@
  "               (suffix is removed from FILENAME, if specified)\n"
  "  -s NUMBER    specify module size in dots (pixels). (default=3)\n"
  "  -l {LMQH}    specify error correction level from L (lowest) to H (highest).\n"
-@@ -166,8 +164,8 @@
+@@ -166,8 +164,8 @@ static void usage(int help, int longopt)
  "  -v NUMBER    specify the version of the symbol. (default=auto)\n"
  "  -m NUMBER    specify the width of the margins. (default=4 (2 for Micro))\n"
  "  -d NUMBER    specify the DPI of the generated PNG. (default=72)\n"
  "  -S           make structured symbols. Version must be specified.\n"
  "  -k           assume that the input text contains kanji (shift-jis).\n"
  "  -c           encode lower-case alphabet characters in 8-bit mode. (default)\n"
-@@ -178,7 +176,7 @@
+@@ -178,7 +176,7 @@ static void usage(int help, int longopt)
  "  --background=RRGGBB[AA]\n"
  "               specify foreground/background color in hexadecimal notation.\n"
  "               6-digit (RGB) or 8-digit (RGBA) form are supported.\n"
  "  -V           display the version number and copyrights of the qrencode.\n"
  "  [STRING]     input data. If it is not specified, data will be taken from\n"
  "               standard input.\n"
-@@ -253,128 +251,6 @@
+@@ -253,128 +251,6 @@ static FILE *openFile(const char *outfil
        return fp;
  }
  
  static int writeEPS(QRcode *qrcode, const char *outfile)
  {
        FILE *fp;
-@@ -831,9 +707,6 @@
+@@ -831,9 +707,6 @@ static void qrencode(const unsigned char
        }
  
        switch(image_type) {
                case EPS_TYPE:
                        writeEPS(qrcode, outfile);
                        break;
-@@ -887,9 +760,6 @@
+@@ -887,9 +760,6 @@ static void qrencodeStructured(const uns
        size_t suffix_size;
  
        switch(image_type) {
                case EPS_TYPE:
                        type_suffix = ".eps";
                        break;
-@@ -948,9 +818,6 @@
+@@ -948,9 +818,6 @@ static void qrencodeStructured(const uns
                }
  
                switch(image_type) {
                        case EPS_TYPE: 
                                writeEPS(p->code, filename);
                                break;
-@@ -1062,9 +929,7 @@
+@@ -1062,9 +929,7 @@ int main(int argc, char **argv)
                                }
                                break;
                        case 't':
                                        image_type = EPS_TYPE;
                                } else if(strcasecmp(optarg, "svg") == 0) {
                                        image_type = SVG_TYPE;
-@@ -1133,11 +998,6 @@
+@@ -1133,11 +998,6 @@ int main(int argc, char **argv)
                exit(EXIT_SUCCESS);
        }
  
        if(optind < argc) {
                intext = (unsigned char *)argv[optind];
                length = strlen((char *)intext);
+--- a/configure
++++ b/configure
+@@ -12646,100 +12646,6 @@ else
+   BUILD_TOOLS_FALSE=
+ fi
+-if test x$build_tools = xyes ; then
+-
+-pkg_failed=no
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for png" >&5
+-$as_echo_n "checking for png... " >&6; }
+-
+-if test -n "$png_CFLAGS"; then
+-    pkg_cv_png_CFLAGS="$png_CFLAGS"
+- elif test -n "$PKG_CONFIG"; then
+-    if test -n "$PKG_CONFIG" && \
+-    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\"libpng\"\""; } >&5
+-  ($PKG_CONFIG --exists --print-errors ""libpng"") 2>&5
+-  ac_status=$?
+-  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+-  test $ac_status = 0; }; then
+-  pkg_cv_png_CFLAGS=`$PKG_CONFIG --cflags ""libpng"" 2>/dev/null`
+-                    test "x$?" != "x0" && pkg_failed=yes
+-else
+-  pkg_failed=yes
+-fi
+- else
+-    pkg_failed=untried
+-fi
+-if test -n "$png_LIBS"; then
+-    pkg_cv_png_LIBS="$png_LIBS"
+- elif test -n "$PKG_CONFIG"; then
+-    if test -n "$PKG_CONFIG" && \
+-    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\"libpng\"\""; } >&5
+-  ($PKG_CONFIG --exists --print-errors ""libpng"") 2>&5
+-  ac_status=$?
+-  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+-  test $ac_status = 0; }; then
+-  pkg_cv_png_LIBS=`$PKG_CONFIG --libs ""libpng"" 2>/dev/null`
+-                    test "x$?" != "x0" && pkg_failed=yes
+-else
+-  pkg_failed=yes
+-fi
+- else
+-    pkg_failed=untried
+-fi
+-
+-
+-
+-if test $pkg_failed = yes; then
+-      { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-
+-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+-        _pkg_short_errors_supported=yes
+-else
+-        _pkg_short_errors_supported=no
+-fi
+-        if test $_pkg_short_errors_supported = yes; then
+-              png_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs ""libpng"" 2>&1`
+-        else
+-              png_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs ""libpng"" 2>&1`
+-        fi
+-      # Put the nasty error message in config.log where it belongs
+-      echo "$png_PKG_ERRORS" >&5
+-
+-      as_fn_error $? "Package requirements (\"libpng\") were not met:
+-
+-$png_PKG_ERRORS
+-
+-Consider adjusting the PKG_CONFIG_PATH environment variable if you
+-installed software in a non-standard prefix.
+-
+-Alternatively, you may set the environment variables png_CFLAGS
+-and png_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details." "$LINENO" 5
+-elif test $pkg_failed = untried; then
+-      { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-      { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error $? "The pkg-config script could not be found or is too old.  Make sure it
+-is in your PATH or set the PKG_CONFIG environment variable to the full
+-path to pkg-config.
+-
+-Alternatively, you may set the environment variables png_CFLAGS
+-and png_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-
+-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
+-See \`config.log' for more details" "$LINENO" 5; }
+-else
+-      png_CFLAGS=$pkg_cv_png_CFLAGS
+-      png_LIBS=$pkg_cv_png_LIBS
+-        { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; }
+-
+-fi
+-fi
+-
+ # Check whether --with-tests was given.
+ if test "${with_tests+set}" = set; then :