miredo: Makefile fixes 11467/head
authorNikita Vostokov <yawosk@yandex.com>
Sun, 22 Mar 2020 12:48:28 +0000 (15:48 +0300)
committerNikita Vostokov <yawosk@yandex.com>
Sun, 22 Mar 2020 12:48:28 +0000 (15:48 +0300)
* Move CONFIGURE blocks after description
* Fix build with libcap

Signed-off-by: Nikita Vostokov <yawosk@yandex.com>
ipv6/miredo/Makefile

index b632540fe03fbda9d79bf4c494cf95880d8e1f18..e3498a891cabaebfdcc26aeb4e1b8e268f5d0bb1 100644 (file)
@@ -21,20 +21,6 @@ PKG_LICENSE_FILES:=COPYING
 
 include $(INCLUDE_DIR)/package.mk
 
-CONFIGURE_ARGS+= \
-               --enable-shared \
-               --enable-static \
-               --disable-binreloc \
-               --with-pic \
-               --without-libiconv-prefix \
-               --without-libintl-prefix
-
-TARGET_CFLAGS+= $(FPIC) \
-               -ffunction-sections \
-               -fdata-sections
-
-TARGET_LDFLAGS += -Wl,--gc-sections
-
 define Package/miredo
        SECTION:=net
        CATEGORY:=Network
@@ -50,6 +36,24 @@ define Package/miredo/description
  IPv6 connectivity even from behind NAT devices.
 endef
 
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --disable-binreloc \
+       --with-pic \
+       --without-libiconv-prefix \
+       --without-libintl-prefix
+
+CONFIGURE_VARS += \
+       ac_cv_header_sys_capability_h=no
+
+TARGET_CFLAGS+= \
+       $(FPIC) \
+       -ffunction-sections \
+       -fdata-sections
+
+TARGET_LDFLAGS += -Wl,--gc-sections
+
 define Package/miredo/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/