ddns-scripts: fix dynv6.com "unchanged" response 4996/head
authorErnest Moshkov <e.moshkov@gmail.com>
Sun, 22 Oct 2017 13:57:07 +0000 (16:57 +0300)
committerErnest Moshkov <e.moshkov@gmail.com>
Sun, 22 Oct 2017 14:08:38 +0000 (17:08 +0300)
Maintainer: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Run tested: LEDE Reboot 17.01.3 r3533-d0bf257c46

Description:

user.err ddns-scripts: IP update not accepted by DDNS Provider

dynv6.com response "unchanged" is OK

Signed-off-by: Ernest Moshkov <e.moshkov@gmail.com>
net/ddns-scripts/Makefile
net/ddns-scripts/files/services
net/ddns-scripts/files/services_ipv6

index 2d544e94722a1a6935b9de75e103fc1dc975936d..af66ba2f2038cac6eb776c87dea6e95ec677c501 100755 (executable)
@@ -12,7 +12,7 @@ PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.7.6
 # Release == build
 # increase on changes of services files or tld_names.dat
-PKG_RELEASE:=18
+PKG_RELEASE:=19
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
index 1140261fef0fffe7aa13a3c383c7cf5a556556c9..c717370ee8bad4e483e709f855aa833970c0f87c 100644 (file)
 
 "dynu.com"             "http://api.dynu.com/nic/update?hostname=[DOMAIN]&myip=[IP]&username=[USERNAME]&password=[PASSWORD]"
 
-"dynv6.com"            "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv4=[IP]"      "updated"
+"dynv6.com"            "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv4=[IP]"      "updated|unchanged"
 
 "easydns.com"          "http://[USERNAME]:[PASSWORD]@api.cp.easydns.com/dyn/generic.php?hostname=[DOMAIN]&myip=[IP]"   "NOERROR"
 
index c593aef6487a3999f803a98574234b89598a0d2f..3ea2974b166eac243c1d8f8cc50bddd56b046f26 100644 (file)
@@ -67,7 +67,7 @@
 
 "dynu.com"    "http://api.dynu.com/nic/update?hostname=[DOMAIN]&myipv6=[IP]&username=[USERNAME]&password=[PASSWORD]"
 
-"dynv6.com"            "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv6=[IP]"      "updated"
+"dynv6.com"            "http://dynv6.com/api/update?hostname=[DOMAIN]&token=[PASSWORD]&ipv6=[IP]"      "updated|unchanged"
 
 "goip.de"              "http://www.goip.de/setip?username=[USERNAME]&password=[PASSWORD]&subdomain=[DOMAIN]&ip6=[IP]"