curl: bugfix: building as selected package doesn't break build 19770/head
authorStan Grishin <stangri@melmac.ca>
Wed, 2 Nov 2022 07:17:08 +0000 (07:17 +0000)
committerStan Grishin <stangri@melmac.ca>
Wed, 2 Nov 2022 07:46:42 +0000 (07:46 +0000)
* Reported-by: Chen Minqiang <ptpt52@gmail.com>
* details [here](https://github.com/openwrt/packages/commit/88009b2d5e394c1822ec55734b63b434981a2a9d#commitcomment-88604318)

Signed-off-by: Stan Grishin <stangri@melmac.ca>
net/curl/Makefile

index 6b96d739b50f7161021c018185bef43fc43928e9..1b19a031856d610aa27ea3e99d55530ec3b4f4cf 100644 (file)
@@ -124,6 +124,7 @@ CONFIGURE_ARGS += \
        \
        $(call autoconf_bool,CONFIG_IPV6,ipv6) \
        \
+       $(if $(CONFIG_LIBCURL_WOLFSSL)$(CONFIG_LIBCURL_GNUTLS)$(CONFIG_LIBCURL_OPENSSL)$(CONFIG_LIBCURL_MBEDTLS),,--without-ssl) \
        $(if $(CONFIG_LIBCURL_WOLFSSL),--with-wolfssl="$(STAGING_DIR)/usr",--without-wolfssl) \
        $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
        $(if $(CONFIG_LIBCURL_OPENSSL),--with-openssl="$(STAGING_DIR)/usr",--without-openssl) \