python3: Centralize config file adjustments in Build/Install
authorJeffery To <jeffery.to@gmail.com>
Thu, 29 Jun 2023 08:13:52 +0000 (16:13 +0800)
committerJeffery To <jeffery.to@gmail.com>
Thu, 24 Aug 2023 17:47:43 +0000 (01:47 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python3/Makefile
lang/python/python3/files/python3-package-dev.mk

index 304e2430418d6540814544195282dd11a8effe31..6e364e45eadbc733b0df9e8f39a5f0e9be5310f9 100644 (file)
@@ -31,7 +31,6 @@ PYTHON3_PKG_BUILD:=0
 include ../python3-package.mk
 
 PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1
 # LTO is handled here individually, see --with-lto below
@@ -149,7 +148,7 @@ installation.
 endef
 
 # Set READELF here so that the exact same readelf program name can be
-# replaced in _sysconfigdata.py (in Py3Package/python3-base/install)
+# replaced in _sysconfigdata.py (in Build/Install)
 TARGET_CONFIGURE_OPTS+= \
        READELF="$(TARGET_CROSS)readelf"
 
@@ -197,6 +196,14 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_IPV6),--enable-ipv6) \
        $(if $(findstring mips,$(CONFIG_ARCH)),,--with-lto)
 
+define Build/Install
+       $(call Build/Install/Default,)
+
+       $(SED) 's|$(TARGET_AR)|ar|g;s|$(TARGET_CROSS)readelf|readelf|g;s|$(TARGET_CC)|gcc|g;s|$(TARGET_CXX)|g++|g' \
+               $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON3_VERSION)/_sysconfigdata.py \
+               $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON3_VERSION)/config-$(PYTHON3_VERSION)/Makefile
+endef
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
        $(INSTALL_DIR) $(2)/bin
@@ -270,9 +277,6 @@ define Py3Package/python3-base/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(LN) python$(PYTHON3_VERSION) $(1)/usr/bin/python3
        $(LN) python$(PYTHON3_VERSION) $(1)/usr/bin/python
-  # This depends on being called before filespec is processed
-       $(SED) 's|$(TARGET_AR)|ar|g;s|$(TARGET_CROSS)readelf|readelf|g;s|$(TARGET_CC)|gcc|g;s|$(TARGET_CXX)|g++|g' \
-               $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON3_VERSION)/_sysconfigdata.py
 endef
 
 Py3Package/python3-light/install:=:
index d9b7e7284299dacbb095d2b65f63ef6ba34ee2e3..3eca521ffa4fceacd1774f3d0a5e59b1a8e519ea 100644 (file)
@@ -24,9 +24,6 @@ define Py3Package/python3-dev/install
        $(LN) python$(PYTHON3_VERSION)-config $(1)/usr/bin/python3-config
        $(LN) python$(PYTHON3_VERSION)-config $(1)/usr/bin/python-config
        $(LN) python$(PYTHON3_VERSION)/config-$(PYTHON3_VERSION)/libpython$(PYTHON3_VERSION).a $(1)/usr/lib/
-  # This depends on being called before filespec is processed
-       $(SED) 's|$(TARGET_AR)|ar|g;s|$(TARGET_CROSS)readelf|readelf|g;s|$(TARGET_CC)|gcc|g;s|$(TARGET_CXX)|g++|g' \
-               $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON3_VERSION)/config-$(PYTHON3_VERSION)/Makefile
 endef
 
 $(eval $(call Py3BasePackage,python3-dev, \