ser2net: update to 4.3.6 18739/head
authorMichael Heimpold <mhei@heimpold.de>
Fri, 10 Jun 2022 20:46:34 +0000 (22:46 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Sat, 11 Jun 2022 10:17:51 +0000 (12:17 +0200)
We need to add an upstream patch as well, which fixes disabling
the newly introduced PAM support.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
net/ser2net/Makefile
net/ser2net/patches/001-fix-disabling-pam.patch [new file with mode: 0644]

index abb1fa64bb4e6de73c937b677ec0dcfcc4748a02..233a9c633edf4a2228b4dd68750938bdb25f3e3d 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ser2net
-PKG_VERSION:=4.3.5
+PKG_VERSION:=4.3.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ser2net
-PKG_HASH:=848c4fe863806e506832f1ee85b8b68258f06eb19dad43dbeee16a2cfe5d9053
+PKG_HASH:=65515c7e9a5289167ae64c4032450904449a87ce20653241022af4f5db2e9510
 
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING
@@ -25,6 +25,7 @@ PKG_INSTALL:=1
 include $(INCLUDE_DIR)/package.mk
 
 CONFIGURE_ARGS += \
+       --with-pam=no \
        --with-pthreads \
        --with-sysfs-led-support
 
diff --git a/net/ser2net/patches/001-fix-disabling-pam.patch b/net/ser2net/patches/001-fix-disabling-pam.patch
new file mode 100644 (file)
index 0000000..02417d9
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -39,7 +39,7 @@ AC_ARG_WITH(pam,
+     fi,
+ )
+-if test "use_pam" != "no"; then
++if test "$use_pam" != "no"; then
+   have_pam=yes
+   AC_CHECK_HEADER(security/pam_appl.h, [], [have_pam=no])
+   if test "$have_pam" = "yes"; then