Merge pull request #23263 from ffontaine/fix-sudo-cpeid
authorAlexandru Ardelean <alex@shruggie.ro>
Sat, 3 Feb 2024 06:12:38 +0000 (08:12 +0200)
committerGitHub <noreply@github.com>
Sat, 3 Feb 2024 06:12:38 +0000 (08:12 +0200)
admin/sudo: fix PKG_CPE_ID

libs/libidn2/Makefile
net/curl/Makefile
net/curl/patches/200-no_docs_tests.patch
utils/squashfs-tools/Makefile

index d080cfcda25eac17e77765fcf487e932ff2fdf87..b536ee527207eb6924af513497f7edf2495a1108 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libidn2
-PKG_VERSION:=2.3.4
+PKG_VERSION:=2.3.7
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=@GNU/libidn
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=93caba72b4e051d1f8d4f5a076ab63c99b77faee019b72b9783b267986dbb45f
+PKG_HASH:=4c21a791b610b9519b9d0e12b8097bf2f359b12f8dd92647611a929e6bfd7d64
 
 PKG_MAINTAINER:=
 PKG_CPE_ID:=cpe:/a:libidn2_project:libidn2
index c41e9ee57a5fd7d54bfd859d01ae9f335b91edda..1969d2dee7dfc4cc199ff62badc97c7e73c20935 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/nls.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=8.5.0
+PKG_VERSION:=8.6.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,
        https://dl.uxnr.de/mirror/curl/ \
        https://curl.askapache.com/download/ \
        https://curl.se/download/
-PKG_HASH:=ce4b6a6655431147624aaf582632a36fe1ade262d5fab385c60f78942dd8d87b
+PKG_HASH:=b4785f2d8877fa92c0e45d7155cf8cc6750dbda961f4b1a45bcbec990cf2fa9b
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index 38f323e26b59e42f59b9a6afab3e45de65a91091..4e0ec1aa3e65ec801e75802d50d42b6c5e32068b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -134,7 +134,7 @@ CLEANFILES = $(VC14_LIBVCXPROJ) \
+@@ -135,7 +135,7 @@ CLEANFILES = $(VC14_LIBVCXPROJ) $(VC14_S
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
@@ -9,7 +9,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -248,8 +248,6 @@ cygwinbin:
+@@ -243,8 +243,6 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        (cd include && $(MAKE) install)
index 04628bc35fd419b4a37257203a419e78538ed897..8a8b72b2f0477b78073f52652befb0d5856a2324 100644 (file)
@@ -14,7 +14,7 @@ PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=COPYING
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
-PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
+PKG_CPE_ID:=cpe:/a:squashfs-tools_project:squashfs-tools
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/plougher/squashfs-tools/tar.gz/${PKG_VERSION}?