Merge pull request #22055 from pprindeville/modem-manager-fix-no-mbim-install
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 6 Sep 2023 06:08:53 +0000 (08:08 +0200)
committerGitHub <noreply@github.com>
Wed, 6 Sep 2023 06:08:53 +0000 (08:08 +0200)
modemmanager: handle no *.conf files being installed

lang/lua-eco/Makefile
libs/libedit/Makefile
net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/share/ddns/default/desec.io.json
net/modemmanager/files/10-report-down
net/modemmanager/files/modemmanager.proto
net/v2ray-geodata/Makefile
net/v2raya/Makefile

index 02e382137f327c70fb39a801744474c8b3ad1a97..e4f3ab188fa893f507980b3e9a2b2a0716951ceb 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua-eco
-PKG_VERSION:=2.5.0
+PKG_VERSION:=2.5.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL=https://github.com/zhaojh329/lua-eco/releases/download/v$(PKG_VERSION)
-PKG_HASH:=d41668d137780f2655ebfec88276249bb9cd5c53f758c3e2103eb001ed9b5d02
+PKG_HASH:=436c09dd7dbc88ab651ae7696f2102b5635628ab420cc550bc237ecb04cade5d
 
 PKG_MAINTAINER:=Jianhui Zhao <zhaojh329@gmail.com>
 PKG_LICENSE:=MIT
index 9192ff26afab7a7628972a1cb045f26fb39e5045..bc60c53f86b994a11949bcfa4abf075ee74e1e87 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libedit
-PKG_VERSION:=20221030-3.1
+PKG_VERSION:=20230828-3.1
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Daniel Salzman <daniel.salzman@nic.cz>
@@ -16,7 +16,7 @@ PKG_LICENSE:=BSD-3-Clause
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thrysoee.dk/editline/
-PKG_HASH:=f0925a5adf4b1bf116ee19766b7daa766917aec198747943b1c4edf67a4be2bb
+PKG_HASH:=4ee8182b6e569290e7d1f44f0f78dac8716b35f656b76528f699c69c98814dad
 
 PKG_INSTALL:=1
 
index 1512fa31b527066ed9fea1e4bb8606e71aede24f..a4c79b06b50ddfc18aafd700b31e0b15a46101e9 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.8.2
-PKG_RELEASE:=38
+PKG_RELEASE:=39
 
 PKG_LICENSE:=GPL-2.0
 
index 4d3d217205caff8cf396104ad0d58361bc413d37..c28458fee6fe8f4bc442c2cdbdb8365afca49b71 100644 (file)
@@ -1,11 +1,11 @@
 {
        "name": "desec.io",
        "ipv4": {
-               "url": "http://update.dedyn.io/update?username=[USERNAME]&password=[PASSWORD]&hostname=[DOMAIN]&myipv4=[IP]&myipv6=preserve",
+               "url": "https://update.dedyn.io/update?username=[USERNAME]&password=[PASSWORD]&hostname=[DOMAIN]&myipv4=[IP]&myipv6=preserve",
                "answer": "good|nochg"
        },
        "ipv6": {
-               "url": "http://update.dedyn.io/update?username=[USERNAME]&password=[PASSWORD]&hostname=[DOMAIN]&myipv6=[IP]&myipv4=preserve",
+               "url": "https://update.dedyn.io/update?username=[USERNAME]&password=[PASSWORD]&hostname=[DOMAIN]&myipv6=[IP]&myipv4=preserve",
                "answer": "good|nochg"
        }
 }
index a3e5fb4ba7a7dee7822d19e9557caff9be736077..88b010cf064015e0fbd9b44ce1cce0d0a95c39e6 100755 (executable)
@@ -29,7 +29,12 @@ MODEM_DEVICE=$(modemmanager_get_field "${MODEM_STATUS}" "modem.generic.device")
 CFG=$(mm_get_modem_config "${MODEM_DEVICE}")
 [ -n "${CFG}" ] || exit 3
 
-logger -t "modemmanager" "interface ${CFG} (network device ${INTERFACE}) ${STATE}"
-proto_init_update $INTERFACE 0
-proto_send_update $CFG
+IFUP=$(ifstatus "${CFG}" | jsonfilter -e "@.up")
+
+[ "${IFUP}" = "true" ] && {
+       logger -t "modemmanager" "interface ${CFG} (network device ${INTERFACE}) ${STATE}"
+       proto_init_update $INTERFACE 0
+       proto_send_update $CFG
+}
+
 exit 0
index e97b768d0b533452ef084193712358f6ff9ff36c..a4d837c1e51420f25bb1babe9ca28ba331e30d90 100755 (executable)
@@ -323,15 +323,6 @@ modemmanager_connected_method_static_ipv6() {
        proto_send_update "${interface}"
 }
 
-modemmanager_disconnected_method_common() {
-       local interface="$1"
-
-       echo "running disconnection (common)"
-
-       proto_init_update "*" 0
-       proto_send_update "${interface}"
-}
-
 proto_modemmanager_init_config() {
        available=1
        no_device=1
@@ -628,7 +619,6 @@ proto_modemmanager_teardown() {
 
        # disconnection handling only requires special treatment in IPv4/PPP
        [ "${bearermethod_ipv4}" = "ppp" ] && modemmanager_disconnected_method_ppp_ipv4 "${interface}"
-       modemmanager_disconnected_method_common "${interface}"
 
        # disconnect
        mmcli --modem="${device}" --simple-disconnect ||
@@ -640,9 +630,6 @@ proto_modemmanager_teardown() {
        # low power, only if requested
        [ "${lowpower:-0}" -lt 1 ] ||
                mmcli --modem="${device}" --set-power-state-low
-
-       proto_init_update "*" 0
-       proto_send_update "$interface"
 }
 
 [ -n "$INCLUDE_ONLY" ] || {
index 3eb1fef6a3a57d48f09105ab08584f8817d76af3..9cc4d32654748e5879ce03c8ca86f45907d656ab 100644 (file)
@@ -12,22 +12,22 @@ PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
 
 include $(INCLUDE_DIR)/package.mk
 
-GEOIP_VER:=202308030045
+GEOIP_VER:=202308310037
 GEOIP_FILE:=geoip.dat.$(GEOIP_VER)
 define Download/geoip
   URL:=https://github.com/v2fly/geoip/releases/download/$(GEOIP_VER)/
   URL_FILE:=geoip.dat
   FILE:=$(GEOIP_FILE)
-  HASH:=9b7fa7407f35e3087f3b052d12ed40974182c6e1864570b848c1ec901292ea82
+  HASH:=536d7aa9f54af747153d4f982adaa3181025dd72faaba8f532b3f514b467eff8
 endef
 
-GEOSITE_VER:=20230803193133
+GEOSITE_VER:=20230905081311
 GEOSITE_FILE:=dlc.dat.$(GEOSITE_VER)
 define Download/geosite
   URL:=https://github.com/v2fly/domain-list-community/releases/download/$(GEOSITE_VER)/
   URL_FILE:=dlc.dat
   FILE:=$(GEOSITE_FILE)
-  HASH:=3d335d493f168eace5414ca1ff54e4f255f8e5b1a90261d2debb1cbefa0666a0
+  HASH:=d393deda756a446ec5247730ef09fed80ba9fb8d9204d1263c45a3604435fe57
 endef
 
 define Package/v2ray-geodata/template
index 9c512debdd79188cd8bf3e36bca42e304ab463d9..eec759a7b328fb6307214b505f11abad3ad318b0 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=v2rayA
-PKG_VERSION:=2.2.2
+PKG_VERSION:=2.2.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=fc32ac028efdd3cac0f482a765ee6e7383b4a8d9be7a343898e64235536cb235
+PKG_HASH:=844da2a4c1ac1f7eae02519a0833255a63938f08a554cbea043606b28ee6ebed
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/service
 
 PKG_LICENSE:=AGPL-3.0-only
@@ -59,7 +59,7 @@ define Download/v2raya-web
        URL:=https://github.com/v2rayA/v2rayA/releases/download/v$(PKG_VERSION)/
        URL_FILE:=web.zip
        FILE:=$(WEB_FILE)
-       HASH:=24e5b61aedb6439f16264be55f50802e1198b87be2d456fc08c44945b67d736b
+       HASH:=2699dacdf39137af408a9ffcb91734e5af487bef4dccaa51f1bb3de6c4d3e8fe
 endef
 
 define Build/Prepare