strongswan: libnttft must not select strongswan 15382/head
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Sat, 10 Apr 2021 02:54:43 +0000 (23:54 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Sat, 10 Apr 2021 02:54:43 +0000 (23:54 -0300)
The strongswan-libnttfft package should not select the strongswan
package, but should depend on it instead.  Otherwise a circular
dependency is created.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
net/strongswan/Makefile

index f2a5dfdd443bffa6d6e57197e4653af3e08e3921..25249c81e81994adeca40a42022331b436994355 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
@@ -377,7 +377,7 @@ endef
 define Package/strongswan-libnttfft
 $(call Package/strongswan/Default)
   TITLE+= nttfft library
-  DEPENDS:= +strongswan
+  DEPENDS:= strongswan
 endef
 
 define Package/strongswan-libnttfft/description