Merge pull request #19520 from dyarkovoy/master
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 5 Oct 2022 14:27:46 +0000 (16:27 +0200)
committerGitHub <noreply@github.com>
Wed, 5 Oct 2022 14:27:46 +0000 (16:27 +0200)
mwan3: support offload routing modifier

13 files changed:
lang/lua-eco/Makefile
libs/libuhttpd/Makefile
libs/libuwsc/Makefile
net/coova-chilli/Makefile
net/curl/Makefile
net/https-dns-proxy/Makefile
net/https-dns-proxy/files/https-dns-proxy.config
net/https-dns-proxy/files/https-dns-proxy.init
net/lighttpd/Makefile
net/openvpn/Makefile
net/strongswan/Makefile
net/wifidog/Makefile
utils/rtty/Makefile

index 6df5a661d2f2776b88afe44e74ae4d4e5a362b15..3aa9aa9dd82c3ff790275f6758602285e9920f63 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua-eco
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL=https://github.com/zhaojh329/lua-eco/releases/download/v$(PKG_VERSION)
index d4d48eb49151b42ca0e4181495a931565c6196c1..85cdcabb1649d9a4e333a709c85235e2e6e7d41c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libuhttpd
 PKG_VERSION:=3.12.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL=https://github.com/zhaojh329/libuhttpd/releases/download/v$(PKG_VERSION)
index 41f7609f0b5dcd77dda26123f4974ae32674f460..0f861ea2b814365dc20eda83ea3c7b7954b5cf75 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libuwsc
 PKG_VERSION:=3.3.5
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=$(AUTORELEASE).1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL=https://github.com/zhaojh329/libuwsc/releases/download/v$(PKG_VERSION)
index ece113869547f48122d9b25ff37e94c53e6fc820..88b98ab44759470cb3799505f1b3f2ff40dfe1e5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coova-chilli
 PKG_VERSION:=1.6
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=$(AUTORELEASE).1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/coova/coova-chilli/tar.gz/$(PKG_VERSION)?
index 53916b0446a78ea6d667bd185ba563c324f28a66..6d0c4848489ce04032eb721a583dee8521a1ffb3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
 PKG_VERSION:=7.85.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=$(AUTORELEASE).1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,$(PKG_VERSION))/ \
index 199f1c5faa2f039aafc6e780bdec39d1ae5d6750..b78c98dc5ec2901d2bdda89de7ed9a600be53434 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=https-dns-proxy
 PKG_VERSION:=2021-11-22
-PKG_RELEASE:=5
+PKG_RELEASE:=7
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
index f08e03ca98cddf8b30cbb0ce662af9bd848f5e60..228d4e450d8e7020ea4ee6ca28603e566325fadc 100644 (file)
@@ -1,5 +1,7 @@
 config main 'config'
        option update_dnsmasq_config '*'
+       option canary_domains_icloud '1'
+       option canary_domains_mozilla '1'
        option force_dns '1'
        list force_dns_port '53'
        list force_dns_port '853'
index 887903fe098649fe3b249aae4d1a70f619d26b66..6bb44512baf408921db1d65fdc500c9496b61a97 100755 (executable)
@@ -24,10 +24,12 @@ readonly PROG=/usr/sbin/https-dns-proxy
 readonly DEFAULT_BOOTSTRAP='1.1.1.1,1.0.0.1,2606:4700:4700::1111,2606:4700:4700::1001,8.8.8.8,8.8.4.4,2001:4860:4860::8888,2001:4860:4860::8844'
 readonly canaryDomainsMozilla='use-application-dns.net'
 readonly canaryDomainsiCloud='mask.icloud.com mask-h2.icloud.com'
-readonly canaryDomains="$canaryDomainsMozilla $canaryDomainsiCloud"
-dnsmasqConfig=
-forceDNS=
-forceDNSPorts=
+canaryDomains=
+canary_domains_icloud=
+canary_domains_mozilla=
+update_dnsmasq_config=
+force_dns=
+force_dns_port=
 
 str_contains() { [ -n "$1" ] &&[ -n "$2" ] && [ "${1//$2}" != "$1" ]; }
 is_mac_address() { expr "$1" : '[0-9A-F][0-9A-F]:[0-9A-F][0-9A-F]:[0-9A-F][0-9A-F]:[0-9A-F][0-9A-F]:[0-9A-F][0-9A-F]:[0-9A-F][0-9A-F]$' >/dev/null; }
@@ -151,10 +153,10 @@ start_instance() {
        procd_set_param stderr 1
        procd_set_param stdout 1
        procd_set_param respawn
-       if [ "$forceDNS" -ne 0 ]; then
+       if [ "$force_dns" -ne 0 ]; then
                procd_open_data
                json_add_array firewall
-               for p in $forceDNSPorts; do
+               for p in $force_dns_port; do
                        if netstat -tuln | grep 'LISTEN' | grep ":${p}" >/dev/null 2>&1 || [ "$p" = '53' ]; then
                                json_add_object ''
                                json_add_string type redirect
@@ -184,11 +186,11 @@ start_instance() {
        if [ "$?" ]; then
                config_get listen_addr "$cfg" 'listen_addr' '127.0.0.1'
                config_get listen_port "$cfg" 'listen_port' "$port"
-               if [ "$dnsmasqConfig" = '*' ]; then
+               if [ "$update_dnsmasq_config" = '*' ]; then
                        config_load 'dhcp'
                        config_foreach dnsmasq_doh_server 'dnsmasq' 'add' "${listen_addr}" "${listen_port}"
-               elif [ -n "$dnsmasqConfig" ]; then
-                       for i in $dnsmasqConfig; do
+               elif [ -n "$update_dnsmasq_config" ]; then
+                       for i in $update_dnsmasq_config; do
                                if [ -n "$(uci_get 'dhcp' "@dnsmasq[$i]")" ]; then
                                        dnsmasq_doh_server "@dnsmasq[$i]" 'add' "${listen_addr}" "${listen_port}"
                                elif [ -n "$(uci_get 'dhcp' "$i")" ]; then
@@ -198,7 +200,7 @@ start_instance() {
                fi
                output_ok
                port="$((port+1))"
-               forceDNS=0
+               force_dns=0
        else
                output_fail
        fi
@@ -208,9 +210,17 @@ start_service() {
        local port=5053
        output "Starting $serviceName "
        config_load "$packageName"
-       config_get dnsmasqConfig        'config' 'update_dnsmasq_config' '*'
-       config_get_bool forceDNS        'config' 'force_dns' '1'
-       config_get forceDNSPorts        'config' 'force_dns_port' '53 853'
+       config_get update_dnsmasq_config        'config' 'update_dnsmasq_config' '*'
+       config_get_bool canary_domains_icloud   'config' 'canary_domains_icloud' '1'
+       config_get_bool canary_domains_mozilla  'config' 'canary_domains_mozilla' '1'
+       config_get_bool force_dns                     'config' 'force_dns' '1'
+       config_get force_dns_port                     'config' 'force_dns_port' '53 853'
+       if [ "$canary_domains_icloud" -ne 0 ]; then
+               canaryDomains="${canaryDomains:+$canaryDomains }${canaryDomainsiCloud}"
+       fi
+       if [ "$canary_domains_mozilla" -ne 0 ]; then
+               canaryDomains="${canaryDomains:+$canaryDomains }${canaryDomainsMozilla}"
+       fi
        dhcp_backup 'create'
        config_load "$packageName"
        config_foreach start_instance "$packageName"
@@ -225,7 +235,7 @@ stop_service() {
        local s=0
        output "Stopping $serviceName "
        config_load "$packageName"
-       config_get dnsmasqConfig 'config' 'update_dnsmasq_config' '*'
+       config_get update_dnsmasq_config 'config' 'update_dnsmasq_config' '*'
        dhcp_backup 'restore'
        if [ -n "$(uci_changes dhcp)" ]; then
                uci_commit 'dhcp'
@@ -255,9 +265,9 @@ dnsmasq_doh_server() {
        local cfg="$1" param="$2" address="${3:-127.0.0.1}" port="$4" i
        case "$param" in
                add)
-                       if [ "$forceDNS" -ne 0 ]; then
+                       if [ "$force_dns" -ne 0 ]; then
                                for i in $canaryDomains; do
-                                       uci_add_list 'dhcp' "$cfg" 'server' "/${i}/"
+                                       uci_add_list_if_new 'dhcp' "$cfg" 'server' "/${i}/"
                                done
                        fi
                        case $address in
@@ -328,10 +338,10 @@ dhcp_backup() {
        config_load 'dhcp'
        case "$1" in
                create)
-                       if [ "$dnsmasqConfig" = "*" ]; then
+                       if [ "$update_dnsmasq_config" = "*" ]; then
                                config_foreach dnsmasq_create_server_backup 'dnsmasq'
-                       elif [ -n "$dnsmasqConfig" ]; then
-                               for i in $dnsmasqConfig; do
+                       elif [ -n "$update_dnsmasq_config" ]; then
+                               for i in $update_dnsmasq_config; do
                                        if [ -n "$(uci_get 'dhcp' "@dnsmasq[$i]")" ]; then
                                                dnsmasq_create_server_backup "@dnsmasq[$i]"
                                        elif [ -n "$(uci_get 'dhcp' "$i")" ]; then
index 9943969b967f17e637df41c292684fa0848f3dd4..1b882d47ada776812d3e638300a4334ddf210706 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
 PKG_VERSION:=1.4.67
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 # release candidate ~rcX testing; remove for release
 #PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.67
 
index 86c7e88f515f067877be69ff36420a467df16619..489145327296d759c116a49342db35b2df4420f6 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openvpn
 
 PKG_VERSION:=2.5.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=\
        https://build.openvpn.net/downloads/releases/ \
index 76c08fc3d030dcf4655a24630ef32049c4b396af..711641fc8aef464c689af6a8133e9a82f49e1254 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.7
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=$(AUTORELEASE).1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index 900d8a6482185c900976b0ae8448e354591ee55f..28af32498b4be85163704636b5603dff6bcce4c8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifidog
 PKG_VERSION:=1.3.0
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/wifidog/wifidog-gateway
index 0b995eb42b2c89f07f9c4dca69fb3d8b0bf20162..856af6c7335a9560fe936e6ce10e93e508bdcd8e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtty
 PKG_VERSION:=8.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL=https://github.com/zhaojh329/rtty/releases/download/v$(PKG_VERSION)