batman-adv: upgrade package to latest release 2020.0
authorSven Eckelmann <sven@narfation.org>
Fri, 6 Mar 2020 18:59:11 +0000 (19:59 +0100)
committerSven Eckelmann <sven@narfation.org>
Sat, 7 Mar 2020 17:50:13 +0000 (18:50 +0100)
* support latest kernels (3.16 - 5.6)
* coding style cleanups and refactoring
* use wifi tx rates as fallback for the B.A.T.M.A.N. V throughput estimation
* disable deprecated sysfs support by default
* bugs squashed:

  - fix crash during the scheduling of OGMs for removed interfaces

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Config.in
batman-adv/Makefile
batman-adv/src/compat-hacks.h

index 8995cdb5c44b0a54cf7097577bcfd203eaf3071a..70cc48ffe8fc098640c90de7b6549bb11b132771 100644 (file)
@@ -89,7 +89,6 @@ config BATMAN_ADV_DEBUG
 config BATMAN_ADV_SYSFS
        bool "batman-adv sysfs entries"
        depends on PACKAGE_kmod-batman-adv
-       default y
        help
          Say Y here if you want to enable batman-adv device configuration and
          status interface through sysfs attributes. It is replaced by the
index 44a6e4b14bfc9ec395e99e00f074542192daecba..88f4cde8109dc69c024726c8c9cd03bffea76f4d 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batman-adv
 
-PKG_VERSION:=2019.5
-PKG_RELEASE:=0
-PKG_HASH:=29fd11b07842f40fee1782bf7ea512278fc4e483bac3c52cf74f8af0f6fe28ec
+PKG_VERSION:=2020.0
+PKG_RELEASE:=1
+PKG_HASH:=a12a32d1ec65b94b54ca86e6f31ac1b947bf04449aad0c96dfe936746bd0c585
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
index 2085767dcd83400e263313fe29f43c256e8a5dd0..fd6cfe1c39241f9603d08bbff278e029379195a1 100644 (file)
 #endif /* < KERNEL_VERSION(4, 15, 0) */
 
 
+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
+
+#ifndef sizeof_field
+#define sizeof_field(TYPE, MEMBER) sizeof((((TYPE *)0)->MEMBER))
+#endif
+
+#endif /* < KERNEL_VERSION(4, 16, 0) */
+
+
 #if LINUX_VERSION_CODE < KERNEL_VERSION(5, 1, 0)
 
 #include_next <linux/igmp.h>