babeld: Update description in Makefile and fix license path
authorBaptiste Jonglez <git@bitsofnetworks.org>
Mon, 26 Aug 2019 16:12:50 +0000 (18:12 +0200)
committerBaptiste Jonglez <git@bitsofnetworks.org>
Mon, 26 Aug 2019 16:40:35 +0000 (18:40 +0200)
Signed-off-by: Baptiste Jonglez <git@bitsofnetworks.org>
babeld/Makefile

index d419e048da7b54131cd4d8cd3d3f973723330fea..022d0b8471169b5901a786fa1c87680131c32294 100644 (file)
@@ -18,7 +18,7 @@ PKG_HASH:=1e1b3c01dd929177bc8d027aff1494da75e1e567e1f60df3bb45a78d5f1ca0b4
 PKG_MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>, \
        Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
 PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
+PKG_LICENSE_FILES:=LICENCE
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,19 +26,17 @@ define Package/babeld
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
-  TITLE:=A loop-free distance-vector routing protocol
+  TITLE:=A loop-avoiding distance-vector routing protocol
   URL:=https://www.irif.fr/~jch/software/babel/
   DEPENDS:=@IPV6
 endef
 
 define Package/babeld/description
-  Babel is a loop-avoiding distance-vector routing protocol roughly based
-  on DSDV and AODV, but with provisions for link cost estimation and
-  redistribution of routes from other routing protocols.
-  While it is optimised for wireless mesh networks, Babel will also work
-  efficiently on wired networks. It will generate between 1.2 and 2.4 times
-  the amount of routing traffic that RIPng would generate, while
-  never counting to infinity.
+  Babel is a loop-avoiding distance-vector routing protocol for IPv6 and IPv4
+  with fast convergence properties. It is based on the ideas in DSDV, AODV and
+  Cisco's EIGRP, but is designed to work well not only in wired networks but
+  also in wireless mesh networks, and has been extended with support for
+  overlay networks. Babel is in the process of becoming an IETF Standard.
 endef
 
 define Package/babeld/conffiles