Fix Quagga vtysh build against readline 6.3
authorSaverio Proto <zioproto@gmail.com>
Mon, 15 Dec 2014 19:58:19 +0000 (20:58 +0100)
committerSaverio Proto <zioproto@gmail.com>
Mon, 15 Dec 2014 20:02:11 +0000 (21:02 +0100)
quagga/Makefile
quagga/patches/110-vtysh-fix-build-against-readline-6.3.patch [new file with mode: 0644]

index cb88b71f042746adb1a63b2a380ba417bc426a7a..67eedd672fdd6a0ec62fa475f04325b6a7384757 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quagga
 PKG_VERSION:=0.99.22.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=03ef24a448be47beba80efa2152f8a28
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -46,7 +46,7 @@ endef
 
 define Package/quagga
   $(call Package/quagga/Default)
-  DEPENDS:=@BROKEN +librt
+  DEPENDS:=+librt
   MENU:=1
 endef
 
diff --git a/quagga/patches/110-vtysh-fix-build-against-readline-6.3.patch b/quagga/patches/110-vtysh-fix-build-against-readline-6.3.patch
new file mode 100644 (file)
index 0000000..e8c499e
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/vtysh/vtysh.c
++++ b/vtysh/vtysh.c
+@@ -2211,9 +2211,9 @@
+ vtysh_readline_init (void)
+ {
+   /* readline related settings. */
+-  rl_bind_key ('?', (Function *) vtysh_rl_describe);
++  rl_bind_key ('?', (rl_command_func_t *) vtysh_rl_describe);
+   rl_completion_entry_function = vtysh_completion_entry_function;
+-  rl_attempted_completion_function = (CPPFunction *)new_completion;
++  rl_attempted_completion_function = (rl_completion_func_t *) new_completion;
+   /* do not append space after completion. It will be appended
+    * in new_completion() function explicitly. */
+   rl_completion_append_character = '\0';
+