opennds: Makefile refactoring
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 26 Feb 2022 11:28:09 +0000 (12:28 +0100)
committerNick Hainke <vincent@systemli.org>
Sat, 26 Feb 2022 12:47:55 +0000 (13:47 +0100)
- Reorder things
- Fixed SPDX License Identifier
- Added PKG_LICENSE_FILES
- Use two spaces instead of tab

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
opennds/Makefile

index 8acd8c5c0b80d292d860d14b84f2da3448e2254f..6f941049e0a6d94961583a81ae35ad5869550c1c 100644 (file)
@@ -6,40 +6,42 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opennds
-PKG_FIXUP:=autoreconf
 PKG_VERSION:=9.6.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/opennds/opennds/tar.gz/v$(PKG_VERSION)?
-PKG_SOURCE:=opennds-$(PKG_VERSION).tar.gz
 PKG_HASH:=90613e636c668a16eb9d6abfe19715f87cea7000383a53ad6719dec80ff966db
 PKG_BUILD_DIR:=$(BUILD_DIR)/openNDS-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Rob White <rob@blue-wave.net>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
-PKG_LICENSE:=GPL-2.0+
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/opennds
-       SUBMENU:=Captive Portals
-       SECTION:=net
-       CATEGORY:=Network
-       DEPENDS:=+iptables-nft +kmod-ipt-conntrack +kmod-ipt-nat +libmicrohttpd-no-ssl
-       TITLE:=Open public network gateway daemon
-       URL:=https://github.com/opennds/opennds
-       CONFLICTS:=nodogsplash nodogsplash2
+  SUBMENU:=Captive Portals
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+iptables-nft +kmod-ipt-conntrack +kmod-ipt-nat +libmicrohttpd-no-ssl
+  TITLE:=Open public network gateway daemon
+  URL:=https://github.com/opennds/opennds
+  CONFLICTS:=nodogsplash nodogsplash2
 endef
 
 define Package/opennds/description
-       openNDS is a Captive Portal solution that offers an instant way to provide restricted access to the Internet.
-       With little or no configuration, a dynamically generated and adaptive splash page sequence is automatically served.
-       Both client driven Captive Portal Detection (CPD) and gateway driven Captive Portal Identification (CPI - RFC 8910 and RFC 8908) are supported.
-       Internet access is granted by either a click to continue button, or after credential verification as a result of filling in a login form.
-       The package incorporates the FAS API allowing many flexible customisation options.
-       The creation of sophisticated third party authentication applications is fully supported.
-       Internet hosted https portals can be implemented with no security errors, to inspire maximum user confidence.
-       This version requires iptables-nft.
+  openNDS is a Captive Portal solution that offers an instant way to provide restricted access to the Internet.
+  With little or no configuration, a dynamically generated and adaptive splash page sequence is automatically served.
+  Both client driven Captive Portal Detection (CPD) and gateway driven Captive Portal Identification (CPI - RFC 8910 and RFC 8908) are supported.
+  Internet access is granted by either a click to continue button, or after credential verification as a result of filling in a login form.
+  The package incorporates the FAS API allowing many flexible customisation options.
+  The creation of sophisticated third party authentication applications is fully supported.
+  Internet hosted https portals can be implemented with no security errors, to inspire maximum user confidence.
+  This version requires iptables-nft.
 endef
 
 define Package/opennds/install