batman-adv: improve version string
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 11 Nov 2019 11:36:21 +0000 (12:36 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 11 Nov 2019 11:39:26 +0000 (12:39 +0100)
This changes the package version string so it does not start
with "openwrt", but with the base version we are modifying:

So far: openwrt-2019.4-1
Now:    2019.4-openwrt-1

Since it's us modifying version 2019.4 (in this case), this order
is more convenient (and also closer to what the kernel version
string does).

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
batman-adv/Makefile

index c59ebce0cd8642f11c39c083596e83b9e64ecc68..dfebb031eb29565cc4273cd3089da0b4263e157d 100644 (file)
@@ -76,7 +76,7 @@ NOSTDINC_FLAGS = \
        -I$(PKG_BUILD_DIR)/include/ \
        -include backport/backport.h \
        -include $(PKG_BUILD_DIR)/compat-hacks.h \
-       -DBATADV_SOURCE_VERSION=\\\"openwrt-$(PKG_VERSION)-$(PKG_RELEASE)\\\"
+       -DBATADV_SOURCE_VERSION=\\\"$(PKG_VERSION)-openwrt-$(PKG_RELEASE)\\\"
 
 COMPAT_SOURCES = \
        $(if $(CONFIG_BATMAN_ADV_MCAST),../../compat-sources/net/core/skbuff.o,) \