batman-adv: Prevent use from libc headers to not build with BIG_ENDIAN 757/head
authorHendrik Borghorst <hendrikborghorst@gmail.com>
Sat, 27 Nov 2021 11:02:46 +0000 (12:02 +0100)
committerHendrik Borghorst <hendrikborghorst@gmail.com>
Sat, 27 Nov 2021 12:53:53 +0000 (13:53 +0100)
Commit 97d35a552ec5b6ddf7923dd2f9a8eb973526acea of musl introduced the
macros __LITTLE_ENDIAN and __BIG_ENDIAN in alltypes.h. These are pulled
into the compilation of batman-adv. This has the side effect that the
function is_multicast_ether_addr of etherdevice.h in Linux kernel is
compiled as the big endian version and so fails to work properly on
little endian devices.

This commits prevents pulling in header files of musl libc similar to
OpenWRT commit 9ac47ee46918c45b91f4e4d1fa76b1e26b9d57fe

Signed-off-by: Hendrik Borghorst <hendrikborghorst@gmail.com>
batman-adv/Makefile

index db4d8b0b1479209311cb3d5119135529b938eb1b..7f2fca85cce23f65d0a98362e18f2a9f69536e43 100644 (file)
@@ -61,6 +61,7 @@ PKG_EXTRA_CFLAGS:= \
        $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(PKG_EXTRA_KCONFIG)))) \
 
 NOSTDINC_FLAGS = \
+       $(KERNEL_NOSTDINC_FLAGS) \
        -I$(PKG_BUILD_DIR)/net/batman-adv \
        -I$(STAGING_DIR)/usr/include/mac80211-backport \
        -I$(STAGING_DIR)/usr/include/mac80211-backport/uapi \