batman-adv: upgrade package to latest release 2019.5 535/head
authorSven Eckelmann <sven@narfation.org>
Fri, 13 Dec 2019 20:52:25 +0000 (21:52 +0100)
committerSven Eckelmann <sven@narfation.org>
Fri, 13 Dec 2019 21:35:12 +0000 (22:35 +0100)
* support latest kernels (3.16 - 5.5)
* coding style cleanups and refactoring
* bugs squashed:

  - fix DAT candidate selection on little endian systems

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile
batman-adv/src/compat-hacks.h

index c59ebce0cd8642f11c39c083596e83b9e64ecc68..ed3e1c256b20ff690aa7d8edf92d1bfae6faa192 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batman-adv
 
-PKG_VERSION:=2019.4
+PKG_VERSION:=2019.5
 PKG_RELEASE:=0
-PKG_HASH:=de07be3f46dddadc3f9608ca11814ecae534c65ccd7cbfeb9762f8e90a17f660
+PKG_HASH:=29fd11b07842f40fee1782bf7ea512278fc4e483bac3c52cf74f8af0f6fe28ec
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
index 9dd45970d7256a28787655b646a0030f01a8e9e3..2085767dcd83400e263313fe29f43c256e8a5dd0 100644 (file)
@@ -118,6 +118,18 @@ static inline int batadv_access_ok(int type, const void __user *p,
 
 #endif /* < KERNEL_VERSION(5, 0, 0) */
 
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 4, 0)
+
+#ifndef fallthrough
+#if __GNUC__ > 7 && !defined(__CHECKER__)
+# define fallthrough                    __attribute__((__fallthrough__))
+#else
+# define fallthrough                    do {} while (0)  /* fallthrough */
+#endif
+#endif
+
+#endif /* < KERNEL_VERSION(5, 4, 0) */
+
 /* <DECLARE_EWMA> */
 
 #include <linux/version.h>