babeld: new upstream release 1.5.0
authorGabriel Kerneis <gabriel@kerneis.info>
Sun, 1 Jun 2014 13:15:10 +0000 (14:15 +0100)
committerGabriel Kerneis <gabriel@kerneis.info>
Sun, 1 Jun 2014 13:15:10 +0000 (14:15 +0100)
22 May 2014: babeld-1.5.0

  * Added support for an RTT-based metric -- see the description of
    "enable-timestamps" in the manual page.  This work was done by
    Baptiste Jonglez with help from Matthieu Boutier.

babeld/Makefile
babeld/files/babeld.config
babeld/files/babeld.init

index d858ad6c9aed3447689709636d8db6c668db9dd3..d7a9ddcc34f50e7af34adf321bbf48cd7195bf17 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.4.2
-PKG_RELEASE:=2
+PKG_VERSION:=1.5.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=a48e8129f221f66640ae1ccf73190991
+PKG_MD5SUM:=ac884beb644792bdb79f0042755820ee
 
 include $(INCLUDE_DIR)/package.mk
 
index a4f00e68da8cee1d46daca4af7e7a578307cca98..88fdf2de7963a72d04f4dbb5ad00c14dd580e5b6 100644 (file)
@@ -49,6 +49,12 @@ config interface wlan
        # packet loss is expected.  The default is four times the hello
        # interval.
        ## option 'update_interval' '16'
+       # Options to enable and configure RTT-based metric
+       ## option 'enable_timestamps' 'false'
+       ## option 'max_rtt_penalty' '0'
+       ## option 'rtt_decay' '42'
+       ## option 'rtt_min' '10'
+       ## option 'rtt_max' '120'
 
 config interface lan
        option 'ignore' 'true'
index f2cf50ac4cf81bce99e5876f9438d5a37b394a78..0e1f039b5a00787ce0a82bd2aaef8f90a1738027 100755 (executable)
@@ -93,6 +93,11 @@ babel_addif() {
        append_parm "$cfg" 'rxcost' 'rxcost'
        append_parm "$cfg" 'hello_interval' 'hello-interval'
        append_parm "$cfg" 'update_interval' 'update-interval'
+       append_bool "$cfg" 'enable_timestamps' 'enable-timestamps'
+       append_parm "$cfg" 'max_rtt_penalty' 'max-rtt-penalty'
+       append_parm "$cfg" 'rtt_decay' 'rtt-decay'
+       append_parm "$cfg" 'rtt_min' 'rtt-min'
+       append_parm "$cfg" 'rtt_max' 'rtt-max'
 
        append args ' ' "'"
 }