olsrd: update olsrd to 2021-06-01
authorNick Hainke <vincent@systemli.org>
Tue, 1 Jun 2021 13:09:29 +0000 (15:09 +0200)
committerMoritz Warning <moritzwarning@web.de>
Sun, 6 Jun 2021 14:55:51 +0000 (16:55 +0200)
Update olsrd to new version.
Remove upstreamed patches:
- 010-musl.patch
- 011-bison.patch
- 012-gpsd.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
olsrd/Makefile
olsrd/patches/.gitignore [deleted file]
olsrd/patches/010-musl.patch [deleted file]
olsrd/patches/011-bison.patch [deleted file]
olsrd/patches/012-gpsd.patch [deleted file]

index cd9249d32e616e85a7cda510b42efe81868deb24..9a68041b054177a91ce2bb426162efe1dffa7c96 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=olsrd
-PKG_SOURCE_DATE:=2020-06-18
+PKG_SOURCE_DATE:=2021-06-01
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/OLSR/olsrd.git
-PKG_SOURCE_VERSION:=84400e5cf56590cd2bd5bef2d224104d1bac4252
-PKG_MIRROR_HASH:=0511743e53505107fdb38fe1b355e145cd7bc1aa409dd0a6a2815bb14b63af73
+PKG_SOURCE_VERSION:=4e86a40b06ea84885e5903ef5349cd6b24e4a7fe
+PKG_MIRROR_HASH:=9fe818d59da7a9ea846d8b52c3f099c663b2c9daa0c3aaf5d27be0825ee20f92
 
 PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
 PKG_BUILD_PARALLEL:=0
diff --git a/olsrd/patches/.gitignore b/olsrd/patches/.gitignore
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/olsrd/patches/010-musl.patch b/olsrd/patches/010-musl.patch
deleted file mode 100644 (file)
index 3023f43..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/pud/nmealib/src/info.c
-+++ b/lib/pud/nmealib/src/info.c
-@@ -172,7 +172,7 @@ bool nmeaTimeParseDate(const char *s, NmeaTime *date) {
- void nmeaTimeSet(NmeaTime *utc, uint32_t *present, struct timeval *timeval) {
-   struct timeval tv;
-   struct tm tm;
--  long usec;
-+  time_t usec;
-   if (!utc) {
-     return;
diff --git a/olsrd/patches/011-bison.patch b/olsrd/patches/011-bison.patch
deleted file mode 100644 (file)
index b7e6fd5..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/src/cfgparser/local.mk
-+++ b/src/cfgparser/local.mk
-@@ -74,12 +74,8 @@ $(C)oparse.c: $(C)oparse.y $(C)olsrd_conf.h $(C)Makefile
- ifeq ($(VERBOSE),0)
-       @echo "[BISON] $@"
- endif
--      $(MAKECMDPREFIX)$(BISON) -d -o "$@-tmp" "$<"
--      $(MAKECMDPREFIX)sed     -e 's/register //' \
--              -e '/^#line/s/$(call quote,$@-tmp)/$(call quote,$@)/' \
--              < "$@-tmp" >"$@"
--      $(MAKECMDPREFIX)mv "$(subst .c,.h,$@-tmp)" "$(subst .c,.h,$@)"
--      $(MAKECMDPREFIX)$(RM) "$@-tmp" "$(subst .c,.h,$@-tmp)"
-+      $(MAKECMDPREFIX)$(BISON) -d -o "$@" "$<"
-+      $(MAKECMDPREFIX)sed -e 's/register //' "$@" > "$@.o" && mv "$@.o" "$@"
- $(C)oparse.o: CFLAGS := $(filter-out -Wunreachable-code,$(CFLAGS))
diff --git a/olsrd/patches/012-gpsd.patch b/olsrd/patches/012-gpsd.patch
deleted file mode 100644 (file)
index f6790cc..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/pud/src/gpsdclient.c
-+++ b/lib/pud/src/gpsdclient.c
-@@ -370,7 +370,7 @@ void nmeaInfoFromGpsd(struct gps_data_t
-           );
-   gpsdata->set &= ~STATUS_SET; /* always valid */
--  if (gpsdata->status == STATUS_NO_FIX) {
-+  if (gpsdata->fix.status == STATUS_NO_FIX) {
-     nmeaInfoClear(info);
-     nmeaTimeSet(&info->utc, &info->present, NULL);
-     return;