[mcproxy] Update to latest version.
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Sat, 5 Apr 2014 12:00:31 +0000 (14:00 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sat, 5 Apr 2014 12:00:31 +0000 (14:00 +0200)
Avoid building for GCC 4.4 and GCC 4.6 (no c++11 support).
Move to routing and redirection menu.
Config cleanup (disable until configured, protocol info, example instances).

mcproxy/Makefile
mcproxy/files/mcproxy.conf

index b96268ab065db7d93eb1dab92f120594ff375e94..364223d1951a992ce39c39bea1e4e7198efd793e 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mcproxy
-PKG_SOURCE_VERSION:=986523a5d714be5cf6f65e4399045cbfecd415fd
-PKG_VERSION:=2014-03-25-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=df2d117dd67a7948f86d7effc5b9ea8f372466d8
+PKG_VERSION:=2014-04-05-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
@@ -25,9 +25,10 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/mcproxy
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=Multicast Proxy for IGMP/MLD
   URL:=http://mcproxy.realmv6.org
-  DEPENDS:=+libpthread +libstdcpp
+  DEPENDS:=+libpthread +libstdcpp @(!GCC_VERSION_4_4&&!GCC_VERSION_4_6)
 endef
 
 define Package/mcproxy/description
index 533c0f925f9692247ccb9b6de7b05539a0b53928..60a655e545bdd08008de6b807803d166bdb4e9ba 100644 (file)
@@ -2,27 +2,13 @@
 ##-- mcproxy configuration script --##
 ######################################
 
-protocol MLDv2; #IPv6
-protocol IGMPv3; #IPv4
+# Erase or comment out the following line when configured
+disable;
 
-#pinstance myProxy: eth0 ==> eth1 eth2;
-#pinstance my_second_instance: tun1 ==> "vlan-eth0.2";
-
-#
-# This confiugration example creates 
-# a multicast proxy for ipv4 with the 
-# upstream eth0 and two downstreams. 
-#  
-#              |  
-#              |
-#       +------+-----+
-#       |    eth0    |
-#       |            |
-#       |  myProxy   |
-#       |            |
-#       | eth1  eth2 |
-#       +---+----+---+
-#           |    |
-#           |    |
-#
+# Protocol: IGMPv1|IGMPv2|IGMPv3 (IPv4) - MLDv1|MLDv2 (IPv6)
+protocol IGMPv3;
 
+# Proxy Instance: upstream ==> downstream
+pinstance proxy1: eth1 ==> "eth0.1";
+#pinstance proxy2: "eth0.2" ==> "br-lan";
+#pinstance proxy3: eth0 ==> eth1 eth2;