opennds: remove iptables-legacy CONFLICTS
authorJo-Philipp Wich <jo@mein.io>
Tue, 12 Apr 2022 21:59:16 +0000 (23:59 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 12 Apr 2022 22:04:06 +0000 (00:04 +0200)
The opennds software interfaces with netfilter using `iptables` commands,
it does not rely on a specific implementation of the iptables frontend.

Furthermore, the semantically wrong conflict with iptables-legacy
introcduces recursive dependencies in the build system, even for people
not using opendns.

Remove the explicit conflict marker for iptables-legacy.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
opennds/Makefile

index ce801f54e3a12b2eec82f554ad29e380ddf07383..773e7585c07cf8da157fb76d7d9dc1ad25540e73 100644 (file)
@@ -30,7 +30,7 @@ define Package/opennds
   DEPENDS:=+iptables-nft +kmod-ipt-conntrack +kmod-ipt-nat +libmicrohttpd-no-ssl
   TITLE:=Open public network gateway daemon
   URL:=https://github.com/opennds/opennds
-  CONFLICTS:=nodogsplash nodogsplash2 iptables-legacy
+  CONFLICTS:=nodogsplash nodogsplash2
 endef
 
 define Package/opennds/description