babeld: adopt to upstream header-style (#640)
authorPolynomdivision <vincent@systemli.org>
Tue, 9 Feb 2021 21:51:39 +0000 (22:51 +0100)
committerGitHub <noreply@github.com>
Tue, 9 Feb 2021 21:51:39 +0000 (22:51 +0100)
babeld: adopt to upstream header-style

Instead of including the headerfiles that define the structs, we add
forward definitions to our headerfile.

Fixes warning:

ubus.h:67:32: warning: 'struct xroute' declared inside parameter list will not be visible outside of this definition or declaration
 void ubus_notify_xroute(struct xroute *xroute, int kind);
                                ^~~~~~
Signed-off-by: Nick Hainke <vincent@systemli.org>
babeld/Makefile
babeld/src/ubus.c
babeld/src/ubus.h

index ef77f0ad628e194236701ad6bd9af13eb83fae5a..0b611286092464528135c15e100b3d6928f5a677 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
 PKG_VERSION:=1.9.2
-PKG_RELEASE:=4
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
index c97ee0a18bee4c4a27a86271bce6542fc88b32ce..e6d6d68c0047576851af1150ae755a66996da04e 100644 (file)
@@ -2,6 +2,7 @@
 #include <stdlib.h>
 #include <sys/select.h>
 
+#include <libubus.h>
 #include <libubox/blob.h>
 #include <libubox/blobmsg.h>
 #include <libubox/list.h>
index 66ef997a0bb91bb01f48f448f9fb55fab9acfe91..1dd5e6e3c670d407681667c6bbb9496d17c11cd2 100644 (file)
 
 */
 
-#include <libubus.h>
+#include <stdbool.h>
+#include <sys/select.h>
+
+struct babel_route;
+struct neighbour;
+struct xroute;
 
 // Whether to enable ubus bindings (boolean option).
 extern int ubus_bindings;