Merge pull request #596 from neheb/olsr
authorSaverio Proto <zioproto@gmail.com>
Tue, 25 Aug 2020 09:02:02 +0000 (11:02 +0200)
committerGitHub <noreply@github.com>
Tue, 25 Aug 2020 09:02:02 +0000 (11:02 +0200)
olsrd: fix compilation with musl 1.2.x

bird2/Makefile
bird2/patches/010-gcc10.patch [new file with mode: 0644]
bmx7/Makefile
bmx7/patches/010-gcc10.patch [new file with mode: 0644]
opennds/Makefile

index fc3d1c27d2a02d01b0100de04074980730ee1486..6962eedbbb80b0d03d0971aad8f7cb0af48521b9 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird2
 PKG_VERSION:=2.0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
diff --git a/bird2/patches/010-gcc10.patch b/bird2/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..172646b
--- /dev/null
@@ -0,0 +1,30 @@
+From 4bbc10614f3431c37e6352f5a6ea5c693c31021e Mon Sep 17 00:00:00 2001
+From: Maria Matejka <mq@ucw.cz>
+Date: Tue, 4 Feb 2020 10:11:16 +0100
+Subject: [PATCH] Added missing extern
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Thanks to Robert Scheck <bird@robert-scheck.de> who reported it
+and Toke Høiland-Jørgensen <toke@toke.dk> who suggested this patch.
+---
+ nest/route.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/nest/route.h b/nest/route.h
+index d2a07f09..b927db5f 100644
+--- a/nest/route.h
++++ b/nest/route.h
+@@ -458,7 +458,7 @@ typedef struct rta {
+                                          protocol-specific metric is availabe */
+-const char * rta_dest_names[RTD_MAX];
++extern const char * rta_dest_names[RTD_MAX];
+ static inline const char *rta_dest_name(uint n)
+ { return (n < RTD_MAX) ? rta_dest_names[n] : "???"; }
+-- 
+2.26.2
+
index 62cc16b177f5653e40592114ba971db769035400..6e71222457370c5cf7000c356cf58f371d7deeda 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bmx7
 PKG_VERSION:=7.1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/bmx-routing/bmx7/tar.gz/v$(PKG_VERSION)?
diff --git a/bmx7/patches/010-gcc10.patch b/bmx7/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..d2b9fcb
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/bmx.h
++++ b/src/bmx.h
+@@ -290,7 +290,7 @@ enum ADGSN {
+ #define SUCCESS 0
+ #define FAILURE -1
+-const void* FAILURE_PTR;
++extern const void* FAILURE_PTR;
+ #define MAX_SELECT_TIMEOUT_MS 1100 /* MUST be smaller than (1000/2) to fit into max tv_usec */
index 71e8597c391c578ab352e9e3ada978421be41326..2fb801d336edf7f1144a6d97905b0ee43409f95e 100644 (file)
@@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opennds
 PKG_FIXUP:=autoreconf
-PKG_VERSION:=5.1.0
+PKG_VERSION:=6.0.0
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://codeload.github.com/opennds/opennds/tar.gz/v$(PKG_VERSION)?
 PKG_SOURCE:=opennds-$(PKG_VERSION).tar.gz
-PKG_HASH:=738c52d3d889edd02cd5935f5fcbc78fed0bd2163449a1947d00e755b7ae5b08
+PKG_HASH:=fff18a2871039a58a12794ecc6dacf77257f4bcc7bfa994ba9de70e0b786f322
 PKG_BUILD_DIR:=$(BUILD_DIR)/openNDS-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Rob White <rob@blue-wave.net>