hnetd: Bump, use DDZ script, and remove the OpenWrt-specific scripts as they match...
authorMarkus Stenberg <markus.stenberg@iki.fi>
Tue, 15 Sep 2015 08:53:49 +0000 (11:53 +0300)
committerMarkus Stenberg <markus.stenberg@iki.fi>
Tue, 15 Sep 2015 08:54:41 +0000 (11:54 +0300)
hnetd/Makefile
hnetd/files/hnetd.init
hnetd/files/ohp-script [deleted file]
hnetd/files/pcp-script [deleted file]

index 3e92239b5faa79d7e12cfe2307846e8da326503e..df9e9506f0e04f0ed525f54ccc64090bf92083ce 100644 (file)
@@ -7,8 +7,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hnetd
-PKG_SOURCE_VERSION:=c0b0c31b8fa4fbe47208e49685ccc9976532738a
-PKG_VERSION:=2015-09-08-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=d802317b77b02af7b5a6531d2eba1d2b790cac9a
+PKG_VERSION:=2015-09-15-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
@@ -115,8 +115,9 @@ define Package/hnetd-$(BUILD_VARIANT)/install
        $(INSTALL_BIN) ./files/hnetd.init $(1)/etc/init.d/hnetd
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/hnet.config $(1)/etc/config/hnet
-       $(INSTALL_BIN) ./files/ohp-script $(1)/usr/sbin/hnetd-ohp-script
-       $(INSTALL_BIN) ./files/pcp-script $(1)/usr/sbin/hnetd-pcp-script
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/generic/ohp.script $(1)/usr/sbin/hnetd-ohp-script
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/generic/ddz.script $(1)/usr/sbin/hnetd-ddz-script
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/generic/pcp.script $(1)/usr/sbin/hnetd-pcp-script
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/generic/hnetd-routing $(1)/usr/sbin/hnetd-routing
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_BIN) ./files/hnetd.defaults $(1)/etc/uci-defaults/x-hnetd.defaults
index 742de48fdb7d0266f610cb6612136a0b406816cb..3ca2c2e063cfe7a10f011cb2b33f2096550b33c8 100644 (file)
@@ -12,6 +12,8 @@ DNSMASQ_DIR=/tmp/dnsmasq.d
 DNSMASQ_SCRIPT=/etc/init.d/dnsmasq
 OHP_SCRIPT=/usr/sbin/hnetd-ohp-script
 OHP_BINARY=/usr/sbin/ohybridproxy
+DDZ_SCRIPT=/usr/sbin/hnetd-ddz-script
+DDZ_BINARY=/usr/sbin/zonestitcher
 PCP_SCRIPT=/usr/sbin/hnetd-pcp-script
 PCP_BINARY=/usr/sbin/minimalist-pcproxy
 MULTICAST_SCRIPT=/usr/sbin/hnet-multicast
@@ -38,6 +40,10 @@ start_service() {
         then
             procd_append_param command -n "$HOSTNAME"
         fi
+        if [ -f $DDZ_BINARY ]
+        then
+            procd_append_param command -z $DDZ_SCRIPT
+        fi
     fi
        
     # Enable multicast if present and installed
diff --git a/hnetd/files/ohp-script b/hnetd/files/ohp-script
deleted file mode 100644 (file)
index aebaa1d..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/sh 
-#-*-sh-*-
-#
-# $Id: ohp-script $
-#
-# Author: Markus Stenberg <mstenber@cisco.com>
-#
-# Copyright (c) 2014 cisco Systems, Inc.
-#
-# Created:       Fri Jan 17 11:46:30 2014 mstenber
-# Last modified: Mon Feb  3 14:39:15 2014 mstenber
-# Edit time:     15 min
-#
-
-# This is minimalist init.d-like start/stop script for
-# ohybridproxy. However, as ohybridproxy receives it's configuration
-# via command line, the 'start' command is also equivalent to
-# 'restart', and has bunch of extra arguments..
-
-OHP=ohybridproxy
-
-start() {
-    $OHP $* &
-}
-
-stop() {
-    killall -9 $OHP
-}
-
-
-CMD=$1
-# For debugging purposes
-LOGNAME=`basename $0`
-echo "$*" | logger -t "$LOGNAME"
-case $CMD in
-  start)
-    shift
-    stop
-    start $*
-    ;;
-  stop)
-  stop
-    ;;
-  *)
-    echo "Only start [config]/stop supported"
-    exit 1
-  ;;
-esac
diff --git a/hnetd/files/pcp-script b/hnetd/files/pcp-script
deleted file mode 100644 (file)
index 88648d2..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-#-*-sh-*-
-#
-# $Id: pcp-script $
-#
-# Author: Markus Stenberg <mstenber@cisco.com>
-#
-# Copyright (c) 2014 cisco Systems, Inc.
-#
-# Created:       Fri Jan 17 11:46:30 2014 mstenber
-# Last modified: Fri May 30 13:27:57 2014 mstenber
-# Edit time:     16 min
-#
-
-# Copied from ohp-script.. Same idea. Just prod minimalist-pcproxy as
-# needed, hoping the miniupnpd is taken care of by the system.
-
-PCP=minimalist-pcproxy
-
-start() {
-    $PCP $* &
-}
-
-stop() {
-    killall -9 $PCP
-}
-
-
-CMD=$1
-# For debugging purposes
-LOGNAME=`basename $0`
-echo "$*" | logger -t "$LOGNAME"
-case $CMD in
-  start)
-    shift
-    stop
-    start $*
-    ;;
-  stop)
-  stop
-    ;;
-  *)
-    echo "Only start [config]/stop supported"
-    exit 1
-  ;;
-esac