Merge pull request #597 from neheb/oon
authorMoritz Warning <moritzwarning@web.de>
Wed, 30 Sep 2020 15:10:15 +0000 (17:10 +0200)
committerGitHub <noreply@github.com>
Wed, 30 Sep 2020 15:10:15 +0000 (17:10 +0200)
oons-olsrd2: fix compilation with GCC 10

17 files changed:
alfred/Makefile
batctl/Makefile
batman-adv/Makefile
batman-adv/files/lib/netifd/proto/batadv_hardif.sh
bird2/Makefile
bird2/patches/010-gcc10.patch [new file with mode: 0644]
bmx7/Makefile
bmx7/patches/010-gcc10.patch [new file with mode: 0644]
olsrd/Makefile
olsrd/patches/010-musl.patch [new file with mode: 0644]
olsrd/patches/011-bison.patch [new file with mode: 0644]
oonf-dlep-proxy/Makefile
oonf-dlep-proxy/patches/010-gcc10.patch [new file with mode: 0644]
oonf-dlep-radio/Makefile
oonf-dlep-radio/patches/010-gcc10.patch [new file with mode: 0644]
oonf-olsrd2/Makefile
opennds/Makefile

index f52e3a979a01ce6070ea459a66dac4384fd2f646..fcb89ac71b3230a3b67035e9c84cac44c5410905 100644 (file)
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alfred
-PKG_VERSION:=2020.2
-PKG_RELEASE:=2
+PKG_VERSION:=2020.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
-PKG_HASH:=1cca2f600f585455a598c92de6fa2b4307c6fe76dddd9d4d29c7648212db9f5e
+PKG_HASH:=821739e570fc3da9936e70075ec04a3caf3b847cc8702f13a0725e903e637b8d
 
 PKG_MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
 PKG_LICENSE:=GPL-2.0-only MIT
index 895e9ea6735d3ce5727a3293e48b0c0332863db7..d2140c1f82de18b81ea9cac54e1c84cf1a6b3a32 100644 (file)
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batctl
-PKG_VERSION:=2020.2
+PKG_VERSION:=2020.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
-PKG_HASH:=d29cdb53ee68abd5027eae07d9fd645b3f154e0d577efa2666c1334bb6d60efd
+PKG_HASH:=3513f7eb3f61817b6894b90832aa5eba513293f487d174ebc98f1bafc9165c64
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
@@ -154,7 +154,7 @@ config-tables := \
        claimtable \
        dat_cache \
        gateways \
-       loglevel \
+       mcast_flags \
        nc_nodes \
        neighbors \
        originators \
index 5813b05853183a17781bec434c09e8744840dc3a..c44324f1ee779ce8640c7cbb94f24a529a3dbb19 100644 (file)
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batman-adv
-PKG_VERSION:=2020.2
+PKG_VERSION:=2020.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
-PKG_HASH:=a73f5ce72c6efa9dd7bd7cc8daa667d0982e12e40811c978bb652607bb5666a3
+PKG_HASH:=65516dca919ea5be58d141c78bd1f0a94a02a784c5c85fb4e8f27f4226803f73
 PKG_EXTMOD_SUBDIRS:=net/batman-adv
 
 PKG_MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
index 6eb597ff610683ce4d478e83d4515fe518228329..b2f87dd6c24eb67e68da1dc66270d9aa67af8140 100755 (executable)
@@ -8,6 +8,7 @@
 
 proto_batadv_hardif_init_config() {
        proto_config_add_int 'elp_interval'
+       proto_config_add_int 'hop_penalty'
        proto_config_add_string "master"
        proto_config_add_string 'throughput_override'
 }
@@ -17,10 +18,12 @@ proto_batadv_hardif_setup() {
        local iface="$2"
 
        local elp_interval
+       local hop_penalty
        local master
        local throughput_override
 
        json_get_vars elp_interval
+       json_get_vars hop_penalty
        json_get_vars master
        json_get_vars throughput_override
 
@@ -29,6 +32,7 @@ proto_batadv_hardif_setup() {
        batctl meshif "$master" interface -M add "$iface"
 
        [ -n "$elp_interval" ] && batctl hardif "$iface" elp_interval "$elp_interval"
+       [ -n "$hop_penalty" ] && batctl hardif "$iface" hop_penalty "$hop_penalty"
        [ -n "$throughput_override" ] && batctl hardif "$iface" throughput_override "$throughput_override"
 
        proto_init_update "$iface" 1
index fc3d1c27d2a02d01b0100de04074980730ee1486..6962eedbbb80b0d03d0971aad8f7cb0af48521b9 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird2
 PKG_VERSION:=2.0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
diff --git a/bird2/patches/010-gcc10.patch b/bird2/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..172646b
--- /dev/null
@@ -0,0 +1,30 @@
+From 4bbc10614f3431c37e6352f5a6ea5c693c31021e Mon Sep 17 00:00:00 2001
+From: Maria Matejka <mq@ucw.cz>
+Date: Tue, 4 Feb 2020 10:11:16 +0100
+Subject: [PATCH] Added missing extern
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Thanks to Robert Scheck <bird@robert-scheck.de> who reported it
+and Toke Høiland-Jørgensen <toke@toke.dk> who suggested this patch.
+---
+ nest/route.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/nest/route.h b/nest/route.h
+index d2a07f09..b927db5f 100644
+--- a/nest/route.h
++++ b/nest/route.h
+@@ -458,7 +458,7 @@ typedef struct rta {
+                                          protocol-specific metric is availabe */
+-const char * rta_dest_names[RTD_MAX];
++extern const char * rta_dest_names[RTD_MAX];
+ static inline const char *rta_dest_name(uint n)
+ { return (n < RTD_MAX) ? rta_dest_names[n] : "???"; }
+-- 
+2.26.2
+
index 62cc16b177f5653e40592114ba971db769035400..6e71222457370c5cf7000c356cf58f371d7deeda 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bmx7
 PKG_VERSION:=7.1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/bmx-routing/bmx7/tar.gz/v$(PKG_VERSION)?
diff --git a/bmx7/patches/010-gcc10.patch b/bmx7/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..d2b9fcb
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/bmx.h
++++ b/src/bmx.h
+@@ -290,7 +290,7 @@ enum ADGSN {
+ #define SUCCESS 0
+ #define FAILURE -1
+-const void* FAILURE_PTR;
++extern const void* FAILURE_PTR;
+ #define MAX_SELECT_TIMEOUT_MS 1100 /* MUST be smaller than (1000/2) to fit into max tv_usec */
index 7eb05e9840a5e36b4a36519e1cf428e82ea5b981..462a0fcbaa1e4dfdc25d9fd4a53429dc74abd7bf 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=olsrd
 PKG_SOURCE_DATE:=2020-06-18
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/OLSR/olsrd.git
diff --git a/olsrd/patches/010-musl.patch b/olsrd/patches/010-musl.patch
new file mode 100644 (file)
index 0000000..3023f43
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/lib/pud/nmealib/src/info.c
++++ b/lib/pud/nmealib/src/info.c
+@@ -172,7 +172,7 @@ bool nmeaTimeParseDate(const char *s, NmeaTime *date) {
+ void nmeaTimeSet(NmeaTime *utc, uint32_t *present, struct timeval *timeval) {
+   struct timeval tv;
+   struct tm tm;
+-  long usec;
++  time_t usec;
+   if (!utc) {
+     return;
diff --git a/olsrd/patches/011-bison.patch b/olsrd/patches/011-bison.patch
new file mode 100644 (file)
index 0000000..b7e6fd5
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/src/cfgparser/local.mk
++++ b/src/cfgparser/local.mk
+@@ -74,12 +74,8 @@ $(C)oparse.c: $(C)oparse.y $(C)olsrd_conf.h $(C)Makefile
+ ifeq ($(VERBOSE),0)
+       @echo "[BISON] $@"
+ endif
+-      $(MAKECMDPREFIX)$(BISON) -d -o "$@-tmp" "$<"
+-      $(MAKECMDPREFIX)sed     -e 's/register //' \
+-              -e '/^#line/s/$(call quote,$@-tmp)/$(call quote,$@)/' \
+-              < "$@-tmp" >"$@"
+-      $(MAKECMDPREFIX)mv "$(subst .c,.h,$@-tmp)" "$(subst .c,.h,$@)"
+-      $(MAKECMDPREFIX)$(RM) "$@-tmp" "$(subst .c,.h,$@-tmp)"
++      $(MAKECMDPREFIX)$(BISON) -d -o "$@" "$<"
++      $(MAKECMDPREFIX)sed -e 's/register //' "$@" > "$@.o" && mv "$@.o" "$@"
+ $(C)oparse.o: CFLAGS := $(filter-out -Wunreachable-code,$(CFLAGS))
index 28e16fd3e8b77aa6ab9ad92abe9ab06408c57b96..3fcb8fc074728b72f73617c332a0ef8c19cf49db 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-proxy
-PKG_VERSION:=0.14.1-1
-PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
+PKG_VERSION:=v0.15.1
+PKG_REV:=bffb88b040659b237c4c91b6b42dbbb47431750e
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/oonf-dlep-proxy/patches/010-gcc10.patch b/oonf-dlep-proxy/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..c5415fd
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/src-plugins/generic/dlep/radio/dlep_radio_internal.h
++++ b/src-plugins/generic/dlep/radio/dlep_radio_internal.h
+@@ -49,6 +49,6 @@
+ #include "core/oonf_logging.h"
+ /* headers only for use inside the DLEP_RADIO subsystem */
+-enum oonf_log_source LOG_DLEP_RADIO;
++extern enum oonf_log_source LOG_DLEP_RADIO;
+ #endif /* DLEP_RADIO_INTERNAL_H_ */
+--- a/src-plugins/generic/dlep/router/dlep_router_internal.h
++++ b/src-plugins/generic/dlep/router/dlep_router_internal.h
+@@ -49,6 +49,6 @@
+ #include "core/oonf_logging.h"
+ /* headers only for use inside the DLEP_ROUTER subsystem */
+-enum oonf_log_source LOG_DLEP_ROUTER;
++extern enum oonf_log_source LOG_DLEP_ROUTER;
+ #endif /* DLEP_ROUTER_INTERNAL_H_ */
+--- a/src-plugins/generic/nl80211_listener/nl80211_internal.h
++++ b/src-plugins/generic/nl80211_listener/nl80211_internal.h
+@@ -49,6 +49,6 @@
+ #include "core/oonf_logging.h"
+ /* headers only for use inside the NL80211 subsystem */
+-enum oonf_log_source LOG_NL80211;
++extern enum oonf_log_source LOG_NL80211;
+ #endif /* NL80211_INTERNAL_H_ */
index 4357e5b6fa58f2fc2cbb2f826012c6bc19c12551..e2cdc4d5d7d97c9056d9c6565c5daf642f85f22b 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-radio
-PKG_VERSION:=0.14.1-1
-PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
+PKG_VERSION:=v0.15.1
+PKG_REV:=bffb88b040659b237c4c91b6b42dbbb47431750e
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/oonf-dlep-radio/patches/010-gcc10.patch b/oonf-dlep-radio/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..db3f69e
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src-plugins/generic/dlep/radio/dlep_radio_internal.h
++++ b/src-plugins/generic/dlep/radio/dlep_radio_internal.h
+@@ -49,6 +49,6 @@
+ #include "core/oonf_logging.h"
+ /* headers only for use inside the DLEP_RADIO subsystem */
+-enum oonf_log_source LOG_DLEP_RADIO;
++extern enum oonf_log_source LOG_DLEP_RADIO;
+ #endif /* DLEP_RADIO_INTERNAL_H_ */
+--- a/src-plugins/generic/nl80211_listener/nl80211_internal.h
++++ b/src-plugins/generic/nl80211_listener/nl80211_internal.h
+@@ -49,6 +49,6 @@
+ #include "core/oonf_logging.h"
+ /* headers only for use inside the NL80211 subsystem */
+-enum oonf_log_source LOG_NL80211;
++extern enum oonf_log_source LOG_NL80211;
+ #endif /* NL80211_INTERNAL_H_ */
index 727bd16721b09ad05a36780fa52f5d0bc5a6b29f..474b0e40c4d8ae4112092cda07d9f1d0b7e961af 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-olsrd2
-PKG_VERSION:=0.14.1-1
-PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
+PKG_VERSION:=v0.15.1
+PKG_REV:=bffb88b040659b237c4c91b6b42dbbb47431750e
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 71e8597c391c578ab352e9e3ada978421be41326..2fb801d336edf7f1144a6d97905b0ee43409f95e 100644 (file)
@@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opennds
 PKG_FIXUP:=autoreconf
-PKG_VERSION:=5.1.0
+PKG_VERSION:=6.0.0
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://codeload.github.com/opennds/opennds/tar.gz/v$(PKG_VERSION)?
 PKG_SOURCE:=opennds-$(PKG_VERSION).tar.gz
-PKG_HASH:=738c52d3d889edd02cd5935f5fcbc78fed0bd2163449a1947d00e755b7ae5b08
+PKG_HASH:=fff18a2871039a58a12794ecc6dacf77257f4bcc7bfa994ba9de70e0b786f322
 PKG_BUILD_DIR:=$(BUILD_DIR)/openNDS-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Rob White <rob@blue-wave.net>