olsrd: add iptables as dependency
authorNick Hainke <vincent@systemli.org>
Sun, 27 Feb 2022 20:51:41 +0000 (21:51 +0100)
committerNick Hainke <vincent@systemli.org>
Sun, 6 Mar 2022 13:50:28 +0000 (14:50 +0100)
The upcoming OpenWrt version (currently in the master branch) ships
firewall4 by default [1], which uses nftables instead of iptables.

Users might choose to use a compatible layer [2] with iptables-nft,
decide which iptables they want to use, and make appropriate changes
related to fw3/f4[3].

This package requires to use iptables (no matter which variant) for
smart-gw-rules.

[1] https://github.com/openwrt/openwrt/commit/08d9f6e3020b4a149b2007b6ed7d684c49af9bbf
[2] https://www.redhat.com/en/blog/using-iptables-nft-hybrid-linux-firewall
[3] https://github.com/openwrt/openwrt/commit/795e7155cbe3e78669f6821bf7aecb7c4e1e1afb

Signed-off-by: Nick Hainke <vincent@systemli.org>
olsrd/Makefile

index 7c8918c0978757e4988e27df6a926c03ae0abb4e..a5f1152af9c5b4d18b14e4f710249a74d91d49a7 100644 (file)
@@ -34,7 +34,7 @@ endef
 define Package/olsrd
   $(call Package/olsrd/template)
   MENU:=1
-  DEPENDS:=+libpthread +libubus
+  DEPENDS:=+libpthread +libubus +iptables +ip6tables
 endef
 
 define Package/olsrd/conffiles