bcm53xx: build a single device per profile
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index 312e5d62b7cb8eb7624403e04122c510a4ef28a0..5143d3a4aff28341caf10af07ae348fdf06a6935 100644 (file)
@@ -121,6 +121,7 @@ USB2_PACKAGES += kmod-usb-ledtrig-usbport
 USB3_PACKAGES := $(USB2_PACKAGES) kmod-usb3 kmod-phy-bcm-ns-usb3
 
 define Device/Default
+  PROFILES = Generic $$(DEVICE_NAME)
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
   # extract the full dtb name based on the device info
   DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(subst _,-,$(1)).dtb)))