bcm53xx: build a single device per profile
authorRani Hod <rani.hod@gmail.com>
Sat, 30 Sep 2023 19:22:13 +0000 (22:22 +0300)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 26 Oct 2023 11:43:33 +0000 (13:43 +0200)
So far every build of a single bcm53xx Target Profile (it means: when
NOT using CONFIG_TARGET_MULTI_PROFILE) resulted in all target devices
images being built. Now it only builds the one matching selected
profile.

Fixes: #13572
Suggested-by: Jonas Gorski <jonas.gorski@gmail.com>
Signed-off-by: Rani Hod <rani.hod@gmail.com>
[rmilecki: update commit subject + body & move PROFILES line]
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit 802a5f5cb4a7b42d25e82b787d7ab1323a20183f)

target/linux/bcm53xx/image/Makefile

index 312e5d62b7cb8eb7624403e04122c510a4ef28a0..5143d3a4aff28341caf10af07ae348fdf06a6935 100644 (file)
@@ -121,6 +121,7 @@ USB2_PACKAGES += kmod-usb-ledtrig-usbport
 USB3_PACKAGES := $(USB2_PACKAGES) kmod-usb3 kmod-phy-bcm-ns-usb3
 
 define Device/Default
+  PROFILES = Generic $$(DEVICE_NAME)
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
   # extract the full dtb name based on the device info
   DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(subst _,-,$(1)).dtb)))