build: call Host/Uninstall before wiping the host build dir
authorAndre Heider <a.heider@gmail.com>
Sat, 28 Sep 2019 11:10:59 +0000 (13:10 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 21 Oct 2019 12:18:17 +0000 (14:18 +0200)
Uninstall targets may depend on build artefacts, like `make uninstall`
or `ninja uninstall`.

Signed-off-by: Andre Heider <a.heider@gmail.com>
include/host-build.mk

index 827ea6bbfb1be72e38309de3fe48435e3aa8172f..9fc14241c64b69bd3a3a4ad39ca1c301b01139a4 100644 (file)
@@ -190,11 +190,11 @@ ifndef DUMP
   host-install: host-compile
 
   host-clean-build: FORCE
+       $(call Host/Uninstall)
        rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
 
   host-clean: host-clean-build
        $(call Host/Clean)
-       $(call Host/Uninstall)
        rm -rf $(HOST_STAMP_INSTALLED)
 
     ifneq ($(CONFIG_AUTOREMOVE),)