hostapd: fix per-BSS airtime configuration
authorDobroslaw Kijowski <dobo90@gmail.com>
Mon, 16 Nov 2020 19:21:46 +0000 (20:21 +0100)
committerDavid Bauer <mail@david-bauer.net>
Tue, 17 Nov 2020 16:05:20 +0000 (17:05 +0100)
airtime_mode is always parsed as an empty string since it hasn't been
added into hostapd_common_add_device_config function.

Fixes: e289f183 ("hostapd: add support for per-BSS airtime configuration")
Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index 8c884386f2a24a36cb479a82aea3548920e08fe8..9a8a74ced9d1dd3d9f8ed617f74d5a552d97d4e1 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=14
+PKG_RELEASE:=15
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 3dbb983170938312b1a6f7515272ffd2e96caa8a..8a07e4d52ba351a7fa59cc634d7e03158de90f23 100644 (file)
@@ -102,6 +102,8 @@ hostapd_common_add_device_config() {
        config_add_string acs_chan_bias
        config_add_array hostapd_options
 
+       config_add_int airtime_mode
+
        hostapd_add_log_config
 }