enable all packages when DEVELOPER=1, add curl and gmp extensions, fix gd extension...
authorNicolas Thill <nico@openwrt.org>
Mon, 19 Sep 2005 23:06:12 +0000 (23:06 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 19 Sep 2005 23:06:12 +0000 (23:06 +0000)
SVN-Revision: 1948

openwrt/package/Makefile
openwrt/package/php4/Config.in
openwrt/package/php4/Makefile
openwrt/package/php4/ipkg/php4-mod-curl.control [new file with mode: 0644]
openwrt/package/php4/ipkg/php4-mod-gmp.control [new file with mode: 0644]

index ef6a71273095b7156fa65ac1dbe21317587b9d26..99447a8d3d7c82b879117dda8d788a913067bd67 100644 (file)
@@ -293,9 +293,15 @@ openvpn-compile: lzo-compile
 endif
 
 php4-compile: openssl-compile zlib-compile
+ifneq ($(BR2_PACKAGE_PHP4_MOD_CURL),)
+php4-compile: curl-compile
+endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
 php4-compile: libgd-compile libpng-compile
 endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_GMP),)
+php4-compile: gmp-compile
+endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_LDAP),)
 php4-compile: openldap-compile
 endif
index d57bd82d6abbef998358af16ff5ba1266f87e389..47e520fc223def2b6ca81fa7abfbfb1d1ab5eed5 100644 (file)
@@ -10,7 +10,7 @@ comment "Server API --"
 config BR2_PACKAGE_PHP4_CLI
        prompt "...-cli - PHP4 CLI (Command Line Interface)"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        select BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBOPENSSL
        select BR2_PACKAGE_ZLIB
@@ -23,7 +23,7 @@ config BR2_PACKAGE_PHP4_CLI
 config BR2_PACKAGE_PHP4_CGI
        prompt "...-cgi - PHP4 built for CGI"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        select BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBOPENSSL
        select BR2_PACKAGE_ZLIB
@@ -36,7 +36,7 @@ config BR2_PACKAGE_PHP4_CGI
 config BR2_PACKAGE_PHP4_FASTCGI
        prompt "...-fastcgi - PHP4 built for FastCGI"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        select BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBOPENSSL
        select BR2_PACKAGE_ZLIB
@@ -48,78 +48,92 @@ config BR2_PACKAGE_PHP4_FASTCGI
 
 comment "Extensions --"
 
+config BR2_PACKAGE_PHP4_MOD_CURL
+       prompt "...-mod-curl - cURL module"
+       tristate 
+       default m if CONFIG_DEVEL
+       depends BR2_COMPILE_PHP4
+       select BR2_PACKAGE_LIBCURL
+
 config BR2_PACKAGE_PHP4_MOD_FTP
        prompt "...-mod-ftp - FTP module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
 
 config BR2_PACKAGE_PHP4_MOD_GD
        prompt "...-mod-gd - GD graphics library module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBGD
        select BR2_PACKAGE_LIBPNG
 
+config BR2_PACKAGE_PHP4_MOD_GMP
+       prompt "...-mod-gmp - GMP module"
+       tristate 
+       default m if CONFIG_DEVEL
+       depends BR2_COMPILE_PHP4
+       select BR2_PACKAGE_LIBGMP
+
 config BR2_PACKAGE_PHP4_MOD_LDAP
        prompt "...-mod-ldap - LDAP module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBOPENLDAP
 
 config BR2_PACKAGE_PHP4_MOD_MYSQL
        prompt "...-mod-mysql - MySQL module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBMYSQLCLIENT
 
 config BR2_PACKAGE_PHP4_MOD_OPENSSL
        prompt "...-mod-openssl - OpenSSL module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBOPENSSL
 
 config BR2_PACKAGE_PHP4_MOD_PCRE
        prompt "...-mod-pcre - PCRE module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBPCRE
 
 config BR2_PACKAGE_PHP4_MOD_PGSQL
        prompt "...-mod-pgsql - PostgreSQL module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBPQ
 
 config BR2_PACKAGE_PHP4_MOD_SESSION
        prompt "...-mod-session - Sessions module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
 
 config BR2_PACKAGE_PHP4_MOD_SQLITE
        prompt "...-mod-sqlite - SQLite module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBSQLITE2
 
 config BR2_PACKAGE_PHP4_MOD_SOCKETS
        prompt "...-mod-sockets - Sockets module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
 
 config BR2_PACKAGE_PHP4_MOD_XML
        prompt "...-mod-xml - XML module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBEXPAT
 
index a152f737497c65049714ca2f29eaed18410299a7..2644aa4451fd25ede68770c2967750d185a3bffe 100644 (file)
@@ -55,13 +55,29 @@ PKG_CONFIGURE_OPTS:= \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
 
+ifneq ($(BR2_PACKAGE_PHP4_MOD_CURL),)
+PKG_CONFIGURE_OPTS+= --with-curl=shared,"$(STAGING_DIR)/usr"
+else
+PKG_CONFIGURE_OPTS+= --without-curl
+endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
 PKG_CONFIGURE_OPTS+= --with-gd=shared,"$(STAGING_DIR)/usr" \
+       --without-freetype-dir \
+       --without-jpeg-dir \
+       --with-png-dir="$(STAGING_DIR)/usr" \
+       --without-xpm-dir \
+       --without-ttf \
+       --without-t1lib \
        --enable-gd-native-ttf \
-       --with-png-dir="$(STAGING_DIR)/usr"
+       --disable-gd-jis-conv
 else
 PKG_CONFIGURE_OPTS+= --without-gd
 endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_GMP),)
+PKG_CONFIGURE_OPTS+= --with-gmp=shared,"$(STAGING_DIR)/usr"
+else
+PKG_CONFIGURE_OPTS+= --without-gmp
+endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_LDAP),)
 PKG_CONFIGURE_OPTS+= --with-ldap=shared,"$(STAGING_DIR)/usr"
        --with-ldap-sasl="$(STAGING_DIR)/usr"
@@ -99,8 +115,10 @@ $(eval $(call PKG_template,PHP4_CLI,php4-cli,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(eval $(call PKG_template,PHP4_CGI,php4-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_FASTCGI,php4-fastcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
+$(eval $(call PKG_template,PHP4_MOD_CURL,php4-mod-curl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_MOD_FTP,php4-mod-ftp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_MOD_GD,php4-mod-gd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,PHP4_MOD_GMP,php4-mod-gmp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_MOD_LDAP,php4-mod-ldap,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_MOD_MYSQL,php4-mod-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_MOD_OPENSSL,php4-mod-openssl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -111,8 +129,10 @@ $(eval $(call PKG_template,PHP4_MOD_SOCKETS,php4-mod-sockets,$(PKG_VERSION)-$(PK
 $(eval $(call PKG_template,PHP4_MOD_SQLITE,php4-mod-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_MOD_XML,php4-mod-xml,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
+$(eval $(call PKG_mod_template,PHP4_MOD_CURL,curl))
 $(eval $(call PKG_mod_template,PHP4_MOD_FTP,ftp))
 $(eval $(call PKG_mod_template,PHP4_MOD_GD,gd))
+$(eval $(call PKG_mod_template,PHP4_MOD_GMP,gmp))
 $(eval $(call PKG_mod_template,PHP4_MOD_LDAP,ldap))
 $(eval $(call PKG_mod_template,PHP4_MOD_MYSQL,mysql))
 $(eval $(call PKG_mod_template,PHP4_MOD_OPENSSL,openssl))
diff --git a/openwrt/package/php4/ipkg/php4-mod-curl.control b/openwrt/package/php4/ipkg/php4-mod-curl.control
new file mode 100644 (file)
index 0000000..80b3025
--- /dev/null
@@ -0,0 +1,9 @@
+Package: php4-mod-curl
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Anael Orlinski <anael.orlinski@gmail.com>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/php4/
+Depends: php4, libcurl
+Description: cURL module for PHP4
diff --git a/openwrt/package/php4/ipkg/php4-mod-gmp.control b/openwrt/package/php4/ipkg/php4-mod-gmp.control
new file mode 100644 (file)
index 0000000..59143c3
--- /dev/null
@@ -0,0 +1,9 @@
+Package: php4-mod-gmp
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Anael Orlinski <anael.orlinski@gmail.com>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/php4/
+Depends: php4, libgmp
+Description: GMP (GNU MP) module for PHP4