rockchip: enable wifi support for NanoPC T4
authorLu jicong <jiconglu58@gmail.com>
Mon, 24 Jul 2023 08:11:28 +0000 (16:11 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 26 Jul 2023 10:15:20 +0000 (12:15 +0200)
wifi module: AP6356S (BCM4356) SDIO

Signed-off-by: Lu jicong <jiconglu58@gmail.com>
package/kernel/mac80211/broadcom.mk
target/linux/rockchip/image/armv8.mk

index cf80ad2d32603b66ecbae41f9b472ed34c74caa4..13da62a6f469a1a773562f9f4cc4d4785811eba0 100644 (file)
@@ -431,6 +431,7 @@ define KernelPackage/brcmfmac/config
                bool "Enable SDIO bus interface support"
                default y if TARGET_bcm27xx
                default y if TARGET_imx_cortexa7
+               default y if TARGET_rockchip
                default y if TARGET_sunxi
                default n
                help
index e8630921a4079a970cc20fecc75a3ce88f912e25..dc977859a6dd63d950f7f724292f08e766a08f04 100644 (file)
@@ -20,6 +20,7 @@ define Device/friendlyarm_nanopc-t4
   DEVICE_MODEL := NanoPC T4
   SOC := rk3399
   IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
+  DEVICE_PACKAGES := kmod-brcmfmac brcmfmac-nvram-4356-sdio cypress-firmware-4356-sdio
 endef
 TARGET_DEVICES += friendlyarm_nanopc-t4