elfutils: bump to 0.177
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>
Mon, 19 Aug 2019 03:09:05 +0000 (00:09 -0300)
committerHans Dedecker <dedeckeh@gmail.com>
Mon, 19 Aug 2019 20:10:35 +0000 (22:10 +0200)
200-uclibc-ng-compat.patch is upstream now.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
package/libs/elfutils/Makefile
package/libs/elfutils/patches/200-uclibc-ng-compat.patch [deleted file]

index e148df096c07b8ca527e8c97d066ab6c0449361a..c00a6b2f3428f88d749536b455791e96388eda52 100644 (file)
@@ -1,6 +1,5 @@
 #
-# Copyright (C) 2010-2014 OpenWrt.org
-# Copyright (C) 2016-2017 Luiz Angelo Daros de Luca <luizluca@gmail.com>
+# Copyright (C) 2010-2019 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=elfutils
-PKG_VERSION:=0.176
-PKG_RELEASE:=2
+PKG_VERSION:=0.177
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
-PKG_HASH:=eb5747c371b0af0f71e86215a5ebb88728533c3a104a43d4231963f308cd1023
+PKG_HASH:=fa489deccbcae7d8c920f60d85906124c1989c591196d90e0fd668e3dc05042e
 PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
 PKG_LICENSE:=GPL-3.0+
 PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
diff --git a/package/libs/elfutils/patches/200-uclibc-ng-compat.patch b/package/libs/elfutils/patches/200-uclibc-ng-compat.patch
deleted file mode 100644 (file)
index cb56942..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 3 May 2019 17:59:55 +0000 (-0700)
-Subject: lib/color: Fix compilation with uClibc
-X-Git-Url: https://sourceware.org/git/?p=elfutils.git;a=commitdiff_plain;h=b5e8a481d4c9f9cdb26513784c09c57797fa2f46;hp=4628b0ea03a0d029cccbcda1cbfc450b4c5ad1bf
-
-lib/color: Fix compilation with uClibc
-
-elfutils passed -Werror and this call errors on uClibc with a mismatching
-pointer type. Cast to char * to fix.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
-
-diff --git a/lib/ChangeLog b/lib/ChangeLog
-index 0914b2c..7381860 100644
---- a/lib/ChangeLog
-+++ b/lib/ChangeLog
-@@ -1,3 +1,7 @@
-+2019-05-03  Rosen Penev  <rosenp@gmail.com>
-+
-+      * color.c (parse_opt): Cast program_invocation_short_name to char *.
-+
- 2018-11-04  Mark Wielaard  <mark@klomp.org>
-       * bpf.h: Add BPF_JLT, BPF_JLE, BPF_JSLT and BPF_JSLE.
-diff --git a/lib/color.c b/lib/color.c
-index 9ffbf55..20b9698 100644
---- a/lib/color.c
-+++ b/lib/color.c
-@@ -132,7 +132,7 @@ valid arguments are:\n\
-   - 'auto', 'tty', 'if-tty'\n"),
-                    program_invocation_short_name, arg);
-             argp_help (&color_argp, stderr, ARGP_HELP_SEE,
--                       program_invocation_short_name);
-+                       (char *) program_invocation_short_name);
-             exit (EXIT_FAILURE);
-           }
-       }