mpc85xx: add testing kernel for p1020
authorDavid Bauer <mail@david-bauer.net>
Sat, 20 Feb 2021 00:36:06 +0000 (01:36 +0100)
committerDavid Bauer <mail@david-bauer.net>
Sun, 21 Feb 2021 23:56:16 +0000 (00:56 +0100)
CONFIG_REGULATOR is required for the p1020 subtarget, as the AT803X
driver depends on it.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mpc85xx/p1020/config-default
target/linux/mpc85xx/p1020/target.mk

index c4c102ca459966e7dad8f03c994dcc4447441995..28e913824104c58f0ece29f1af8d08bfa4ea8d5b 100644 (file)
@@ -31,8 +31,10 @@ CONFIG_MUTEX_SPIN_ON_OWNER=y
 CONFIG_NET_FLOW_LIMIT=y
 CONFIG_NR_CPUS=2
 CONFIG_PADATA=y
+# CONFIG_PPC_QUEUED_SPINLOCKS is not set
 CONFIG_RCU_STALL_COMMON=y
 CONFIG_REGMAP_IRQ=y
+CONFIG_REGULATOR=y
 CONFIG_RFS_ACCEL=y
 CONFIG_RPS=y
 # CONFIG_RTC_DRV_MAX77686 is not set
index a25409eebbc1caf6bc2cdbd2c080eae245e1b691..2c7f3b42f273f9ac2ae28da48030682929cba912 100644 (file)
@@ -1,6 +1,8 @@
 BOARDNAME:=P1020
 FEATURES+=nand
 
+KERNEL_TESTING_PATCHVER:=5.10
+
 define Target/Description
        Build firmware images for Freescale P1020 based boards.
 endef